Opened 8 years ago

Closed 8 years ago

#12876 closed defect (invalid)

DataGrid + QueryReadStore fails on IE7, IE8 with "This deferred has already been resolved" on dojo 1.6

Reported by: tsemachh Owned by: evan
Priority: high Milestone: 1.7
Component: DojoX Grid Version: 1.6.0
Keywords: DataGrid QueryReadStore Dojo1.6 Cc:
Blocked By: Blocking:

Description

Trying to upgrade to Dojo 1.6 We have many DataGrids? with QueryReadStore? working on IE & FF. when trying to access it after upgrading to Dojo 1.6 we see the Grid on FF & Chrome but on IE7 & 8 it fails on our application with: "This deferred has already been resolved" And on the Test Page attached it just shows Error: "LOG: TypeError?: 'undefined' is null or not an object" BTW: I wrapped in the sample the Grid with dojox Portlet , but it also fails without it.

Attachments (2)

demo_QueryReadStore_grid.html (2.3 KB) - added by tsemachh 8 years ago.
sampleJson.json (1.5 KB) - added by tsemachh 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by tsemachh

Changed 8 years ago by tsemachh

Attachment: sampleJson.json added

comment:1 Changed 8 years ago by tsemachh

Note: Test should be placed at: dojox/data/demos/

comment:2 Changed 8 years ago by tsemachh

You can close this defect as it seems the bug was found . The issue is with the Json provided extra , after the items This somehow works on FF but not on IE.

comment:3 Changed 8 years ago by evan

Milestone: 1.6.21.7
Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.