Opened 9 years ago

Closed 8 years ago

#12850 closed defect (fixed)

dojox.data test suite won't start

Reported by: haysmark Owned by: bill
Priority: high Milestone: 1.7
Component: DojoX Data Version: 1.7.0b1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by haysmark)

See:

http://archive.dojotoolkit.org/dojo-2011-06-15/checkout/util/doh/runner.html?testModule=dojox.data.tests.module

The dojox data tests don't start. In the Log pane, I get different messages depending on which browser I use:

  • IE8: TypeError?: Object doesn't support this property or method
  • IE9: TypeError?: Object doesn't support this property or method 'getObject'

Change History (8)

comment:1 Changed 9 years ago by haysmark

Description: modified (diff)

comment:2 Changed 9 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [24730]) Fixes for issues reported. Caused by new AMD loader. \!strict fixes #12850

comment:3 Changed 9 years ago by Jared Jurkiewicz

Milestone: tbd1.7

comment:4 Changed 8 years ago by haysmark

Resolution: fixed
Status: closedreopened

The dojox.data tests aren't starting again in IE. In IE9 in particular I get the error:

TypeError: Object doesn't support this property or method 'getObject'

comment:5 Changed 8 years ago by haysmark

Description: modified (diff)

comment:6 Changed 8 years ago by haysmark

Version: 1.6.01.7.0b1

comment:7 Changed 8 years ago by haysmark

Owner: changed from Jared Jurkiewicz to bill
Status: reopenednew

Bill, [25490] regressed the dojox.data test suite.

comment:8 Changed 8 years ago by bill

Resolution: fixed
Status: newclosed

(In [25520]) fix missing dependency on dojo/_base/kernel, fixes #12850, refs #12863, #13208 !strict.

Note: See TracTickets for help on using tickets.