Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12833 closed defect (fixed)

plugin dialog stuck open after double click in editor body

Reported by: hengly Owned by:
Priority: high Milestone: 1.7
Component: Editor Version: 1.6.0
Keywords: dialog, editor, toolbar Cc:
Blocked By: Blocking:

Description (last modified by bill)

1.Running the test html

2.Creating a link dialog and input valid link for example(http://www.aol.com), type the description for the link "Aol link"

3.Then the linked text will be presented on the editor body.

4.Double-clicking the text, then the dialog will be displayed again,then clicking the text

Expected: The dialog will be closed after step 4

Actual:

The dialog still represent.

Attachments (1)

test_Editor.html (1.4 KB) - added by hengly 8 years ago.

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by hengly

Attachment: test_Editor.html added

comment:1 Changed 8 years ago by bill

Component: GeneralEditor
Description: modified (diff)
Milestone: tbdfuture
Summary: The dialog of plugins cannot disappear after clicking into the editor bodyplugin dialog stuck open after double click in editor body

That's a strange one, not sure if the problem is in editor or the popup code. I'll take a look eventually unless someone else wants to look first.

comment:2 Changed 8 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [24738]) The dropdown needs to be focused after opening for body click to close it. fixes #12833

comment:3 Changed 8 years ago by Jared Jurkiewicz

Milestone: future1.7

comment:4 Changed 8 years ago by Jared Jurkiewicz

(In [24739]) The dropdown needs to be focused after opening for body click to close it. Same issue in the InsertAnchor? plugin. refs #12833

Note: See TracTickets for help on using tickets.