Opened 9 years ago

Closed 9 years ago

#12804 closed defect (fixed)

TooltipDialog: closes unexpectedly when closing DateTextBox by clicking arrow icon

Reported by: JayZ(zhouxiang) Owned by: bill
Priority: high Milestone: 1.7
Component: Dijit - Form Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

in "test_TooltipDialog.html", open the first "show tooltip dialog", when we open the third one -- "DateTextBox?" and close without choose any date, the DateTextBox? closed and the tooltipDialog is also disappeared.

the correct way is: the DateTextBox? should be closed but the tooltipDialog should not be closed.

Attachments (1)

tooltipDialog_DateTextBox_issue.png (16.3 KB) - added by JayZ(zhouxiang) 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by JayZ(zhouxiang)

comment:1 Changed 9 years ago by bill

Milestone: tbd1.7
Owner: set to bill
Summary: IE issue: dijit.tooltipDialog disappeared when close DateTextBoxTooltipDialog: closes unexpectedly when closing DateTextBox by clicking arrow icon

Ah, you mean that you closed the DateTextBox dropdown by clicking the arrow icon again? Yes, there seems to be a bug there, although for the DateTextBox, not for the Select. I'll take a look. Reproduced on IE7 and IE8 (but working on FF).

comment:2 Changed 9 years ago by bill

Component: DijitDijit - Form

comment:3 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [25313]) On IE, ignore spurious onactivate notifications, rather than treating them as mouse down events. Clicking on the arrow icon of a DateTextBox [when the dropdown Calendar was opened] was generating a spurious onactivate notification with srcElement == <body>, causing the TooltipDialog containing the DateTextBox to close.

Fixes #12804 !strict.

Note: See TracTickets for help on using tickets.