Opened 9 years ago

Closed 9 years ago

#12792 closed defect (duplicate)

wrong layout children lookup or not safe .substring call causes _LayoutWidget regression in 1.6

Reported by: rastrano Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.6.0
Keywords: layout, children, substring Cc:
Blocked By: Blocking:

Description (last modified by bill)

In my environment i wasn't able to deploy a dojo app wich uses a lot of markup declared, nested layout widgets.

The problem was that _LayoutWidget tries to determine a position for each dojo-markedup children element, also dijit.form.Button, and for this element i was getting an error on capitalize function

164                 var capitalize = function(word){
165	                return word.substring(0,1).toUpperCase() + word.substring(1);
166	        };

http://bugs.dojotoolkit.org/browser/dijit/trunk/layout/_LayoutWidget.js?rev=14743

(cannot call substring() on undefined)

if rawly fixed it adding

if(word==undefined) return "Client";

but i think the problem is in getting children layouts elements.

Change History (3)

comment:1 Changed 9 years ago by bill

Component: GeneralDijit

Please attach a test case, although it sounds like the issue is that you forgot to specify a position on one of the children of your layout widget. Also, it's strange to have a Button as a direct child of a layout widget.

comment:2 Changed 9 years ago by bill

Description: modified (diff)

comment:3 Changed 9 years ago by bill

Resolution: duplicate
Status: newclosed

Dup of #12795.

Note: See TracTickets for help on using tickets.