Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#1278 closed defect (fixed)

Node editor doesn't receive focus

Reported by: ornus Owned by: alex
Priority: high Milestone:
Component: Widgets Version: 0.3
Keywords: tree Cc: alex
Blocked by: Blocking:

Description

When node editing starts, the editor doesn't receiv focus automatically. User needs to click on the node one more time to start editing it.

Change History (8)

comment:1 Changed 8 years ago by dylan

  • Milestone changed from 0.4 to 0.5

comment:2 Changed 7 years ago by ilia

  • Cc alex added
  • Owner changed from ilia to liucougar

I think it is fixed, but current editor.html test is broken because of dojo/editor issues.. I don't know how to fix this.

comment:3 Changed 7 years ago by ilia

Try editing node 2 times by pressing edit button, you'll see the bug

comment:4 Changed 7 years ago by liucougar

  • Milestone changed from 0.5 to 0.4.1
  • Owner changed from liucougar to alex

this is caused by r6530

alex, please fix it, as I have no clue either

comment:5 Changed 7 years ago by alex

  • Resolution set to fixed
  • Status changed from new to closed

this was not caused by my patch. We disabled this explicitly before the branch. To turn on focus-on-edit, please set the focusOnLoad property.

comment:6 Changed 7 years ago by alex

  • Resolution fixed deleted
  • Status changed from closed to reopened

problem is real, re-opening

comment:7 Changed 7 years ago by alex

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [6565]) fixes #1278

Thanks to liucougar for keeping at it and sending me a test case.

comment:8 Changed 7 years ago by anonymous

  • Milestone 0.4.1 deleted

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.