Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#12779 closed defect (duplicate)

Tooltip incorrect arrow drawing

Reported by: erik650 Owned by:
Priority: high Milestone: tbd
Component: Dijit Version: 1.6.0
Keywords: tooltip arrow chart Cc: Douglas Hays
Blocked By: Blocking:

Description

Tooltip arrow in 1.6 is drawn different than in 1.5.1. The tooltip tests show a slight difference in the arrow position between 1.5.1 and 1.6.1rc1, however, the tooltip in any of the charts the arrow is drawn much different than in 1.5.1.

Please see the below thread for images showing differences in tooltip arrow drawing. http://dojo-toolkit.33424.n3.nabble.com/Chart-tooltip-1-5-to-1-6-arrow-change-td2841645.html#a2843423

Change History (4)

comment:1 Changed 9 years ago by erik650

Component should be set to Dijit (tooltip).

comment:2 Changed 9 years ago by bill

Cc: Douglas Hays added
Component: GeneralDijit
Resolution: duplicate
Status: newclosed

Actually, what happened was that in 1.6 the charting code was switched to use the dijit tooltip. Dijit tooltip didn't change from 1.5 to 1.6 and it's operating as expected in 1.6, just not the way you want it to.

The good news for you is that in #12418 Doug implemented support for having arrows in the middle of (dijit tooltips). Closing this ticket as a duplicate of that one.

comment:3 in reply to:  2 Changed 9 years ago by erik650

The code to enable tooltips for charts is one line of code:

dojox.charting.action2d.Tooltip(bugsNew.chart, "default");

What is the correct way to notify dojox.charting.action2d.Tooltip to use middle arrows?

comment:4 Changed 9 years ago by bill

You don't need to do anything, other than pull the latest code from trunk SVN, or wait for the 1.7 release.

Note: See TracTickets for help on using tickets.