Opened 8 years ago

Closed 7 years ago

#12778 closed defect (fixed)

[patch] dojox.charting.widgets.Legend fix for markers only

Reported by: olangman Owned by: Eugene Lazutkin
Priority: high Milestone: 1.8
Component: Charting Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hello,

Legend.js contains an improper reference to marker colors that results in a blank space instead of a proper colored icon in the legend. The fix appears to be simple and involves changing the reference for colors to the proper targets.

Diff attached.

Attachments (1)

Legend.js.diff (214 bytes) - added by olangman 8 years ago.
Simple change to use marker colors

Download all attachments as: .zip

Change History (4)

Changed 8 years ago by olangman

Attachment: Legend.js.diff added

Simple change to use marker colors

comment:1 Changed 8 years ago by olangman

To clarify - If you set lines to false or the chart type to MarkersOnly?, when adding a legend the icons will not properly be displayed. This fixes that, but I'm not sure if it breaks anything else.

comment:2 Changed 8 years ago by bill

Summary: dojox.charting.widgets.Legend fix for markers only[patch] dojox.charting.widgets.Legend fix for markers only

Trivial patch, so no CLA needed.

comment:3 Changed 7 years ago by cjolif

Milestone: tbd1.8
Resolution: fixed
Status: newclosed

This is a duplicate of #14259 which is fixed.

Note: See TracTickets for help on using tickets.