Opened 9 years ago

Closed 6 years ago

#12774 closed enhancement (wontfix)

The editor should support an api to set default font and font size

Reported by: hengly Owned by:
Priority: low Milestone: future
Component: Editor Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

  1. Open the rich text editor
  1. Want to set default font and font size

Expected: There is an api to specify the default the font and font size

Got: The font and font size's drop down list are empty.

Attachments (1)

yahoo.jpg (12.0 KB) - added by hengly 9 years ago.
Yahoo's rich text editor default font and font size

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by bill

Component: DijitEditor
Description: modified (diff)
Priority: highlow
Summary: The editor should can surpport an api to set default font and font sizeThe editor should support an api to set default font and font size
Type: defectenhancement

Not sure why your drop down lists were empty, they usually have a list of fonts and font-sizes, both of which lists are customizable. As per setting the initial font/font-size, there is no explicit API for that but it's fairly simple to calling set() on each of those two drop downs.

comment:2 Changed 9 years ago by hengly

Sorry for unclear subscribe for this.The issue is that,the drop down list has the values,but the initial value should be selected for the checkbox without after clicking the list item. Thanks,

Changed 9 years ago by hengly

Attachment: yahoo.jpg added

Yahoo's rich text editor default font and font size

comment:3 Changed 9 years ago by Jared Jurkiewicz

Milestone: tbdfuture

comment:4 Changed 6 years ago by bill

Resolution: wontfix
Status: newclosed

Closing this because it's unlikely we'll support our own editor for Dojo V2.

Note: See TracTickets for help on using tickets.