Opened 8 years ago

Closed 8 years ago

#12731 closed defect (duplicate)

On IE9, browser cursor doesn't show correctly above grid's header.

Reported by: tuanngo Owned by: evan
Priority: high Milestone: 1.6.1
Component: DojoX Grid Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

With grid's columns which are not sort-able, mouse over those column's headers show wrong cursor: resize cursor.

Expect: show resize cursor only mouse over header's border.

Can reproduce this issue by viewing the #1 grid in http://docs.dojocampus.org/dojox/grid/DataGrid, mouse over year column header.

Change History (5)

comment:1 Changed 8 years ago by bill

Component: GeneralDojoX Grid
Owner: set to evan

comment:2 Changed 8 years ago by darth

I believe this bug had a similar issue http://bugs.dojotoolkit.org/ticket/11613

Haven't tried fully, but in the dojo.isMoz check, if I also add a dojo.isIE >= 9 check, IE9 seems to be fine. Will check further.

comment:3 Changed 8 years ago by darth

I noticed that changing the dojo.isIE checks to dojo.isIE < 9 in _Builder.js, like the few under the _HeaderBuilder methods, seem to work fine. Didn't notice any problems with IE9 header and resizing.

comment:4 Changed 8 years ago by darth

comment:5 Changed 8 years ago by evan

Milestone: tbd1.6.1
Resolution: duplicate
Status: newclosed

duplicate with #12737

Note: See TracTickets for help on using tickets.