Opened 9 years ago

Closed 8 years ago

Last modified 7 years ago

#12726 closed defect (worksforme)

dojox.mobile: Cannot select the latter items of ComboBox menu on iPhone

Reported by: ykami Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.6.0
Keywords: 1.7-mobile Cc: koba
Blocked By: Blocking:

Description

Cannot select the latter menu items of ComboBox menu because the keyborad window is overlaid. We need to think about both portrait and landscape cases.

Change History (5)

comment:1 Changed 9 years ago by Chris Mitchell

on mobile devices when popping up lists that can potentially contain more items than possible to display in the viewport, allow user to touch scroll (or mouse/cursor scroll) the items. When the new Opener is available with mobile tooltip dialog, the contents of the dialog will contain the list items, and should be scrollable (possibly both in x and y directions if overflow width/height).

comment:2 Changed 8 years ago by ykami

Cc: koba added
Resolution: worksforme
Status: newclosed

The problem no longer exists. When the keyboard appears, the height of the drop-down is resized automatically.

comment:3 Changed 7 years ago by mtbvfr

Hi,

This is still a problem.

I downloaded Version 1.9 and created a test page, based on one of the examples, at the following address but the iPhone virtual keyboard still covers the list.

http://scantagdatacapture.com.web10.reliabledomainspace.com/DojoComboBoxTest.html

Thank you, Michael.

comment:4 Changed 7 years ago by bill

Perhaps the problem is that iScroll class. If you can come up with a standalone test case that fails (not using code outside of dojo), can you open a new ticket and then attach it? It should be a single HTML file attached using the Attach File button.

comment:5 Changed 7 years ago by mtbvfr

Hi Bill,

I was having the problem before I tried integrating iScroll.

I will lodge a new ticket after I have tried a few other things.

I would like to have the <div id=stateSelect_popup> scrollable.

Thanks, Michael

Note: See TracTickets for help on using tickets.