Opened 9 years ago

Closed 8 years ago

#12708 closed defect (fixed)

[regression] FilteringSelect: displays high-contrast mode X for invalid values (tundra)

Reported by: gerhard presser Owned by: bill
Priority: high Milestone: 1.6.1
Component: Dijit - Form Version: 1.6.0
Keywords: Cc: Douglas Hays
Blocked By: Blocking:

Description

hi, dijit.form.filteringselect looks broken (displays an X) in ie7, if e.g. the 'required' dialog pops-up.

this issue can be reproduced using the dijit-theme-tester, selecting the tundra theme, and clicking on any filteringselect widget.

regards

gerhard


dojo 1.6.0 browser: ie7 os: windows 7

Change History (6)

comment:1 Changed 9 years ago by Douglas Hays

Milestone: tbd1.6.1

This started happening with [22769].

comment:2 Changed 9 years ago by Douglas Hays

Owner: changed from Douglas Hays to bill

comment:3 Changed 9 years ago by bill

Status: newassigned
Summary: dijit.filteringselect layout problem[regression] FilteringSelect: displays high-contrast mode X for invalid values (tundra)

Note that it works on claro, but fails on tundra (not sure about soria/nihilo, I'll check those).

comment:4 Changed 9 years ago by bill

Cc: Douglas Hays added

It's the text-indent: -1em trick to hide the X text (when not in high contrast mode), it works on <input> but doesn't work on an <input/>. Claro isn't affected since it hides the X text by setting the <input> to width: 0.

comment:5 Changed 8 years ago by bill

Oh, nevermind, IE7 has special rules (#text-indent: 0, #letter-spacing: -5em) but for them to work the <input> value needs a space at the end. I inadvertently removed the space in [22769], since it looks like a typo.

comment:6 Changed 8 years ago by bill

Resolution: fixed
Status: assignedclosed

Fixed in [24385] and [24386].

Note: See TracTickets for help on using tickets.