Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12699 closed defect (wontfix)

can not use dojo.window with dojox.mobile in 1.6

Reported by: Luis Montes Owned by: ykami
Priority: high Milestone: tbd
Component: DojoX Mobile Version: 1.6.0
Keywords: mobile viewport Cc:
Blocked By: Blocking:

Description

dojo.window.getBox() worked, in 1.5, but dojo.window is undefined in 1.6 when using dojox.mobile to build a mobile site.

Here's a working test case with 1.5: http://fiddle.jshell.net/monteslu/GFZp5/show/

And a brokent test case with 1.6: http://fiddle.jshell.net/monteslu/KQqxb/show/

Change History (3)

comment:1 Changed 8 years ago by ykami

Resolution: wontfix
Status: newclosed

It is not a bug, but a build configuration issue. Your 1.6 version seems to be a minimal build, which includes minimal base modules. That is, some of the base modules that are usually available are purposefully excluded from the build to reduce the total code size. dojo.window.getBox() is defined in dojo/window.js. The solution is to add dojo.require("dojo.window"); to your app.

comment:2 Changed 8 years ago by bill

Regardless of builds, if you are using any module [outside of dojo/_base] you need to dojo.require() it. Sounds like you just got lucky in 1.5.

comment:3 Changed 8 years ago by Luis Montes

While I don't doubt I got lucky with this, this can be reproduced with just the standard 1.5 & 1.6 google CDN builds. The release notes for 1.6 don't mention that the standard 1.6 builds don't include this functionality any longer.

Note: See TracTickets for help on using tickets.