Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12696 closed defect (duplicate)

[regression] DropDownButton/ComboButton: enter/space key sometimes doesn't open menu on IE

Reported by: bill Owned by: bill
Priority: high Milestone: 1.6.1
Component: Dijit - Form Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

Starting from [22617], if the user slowly presses the enter key or space key to open the drop down, the popup will sometimes flash open but then close again.

The difference is whether the keyup occurs before or after the drop down has gained focus.

Probably happens more on IE9 than IE8 due to IE9's speed increase. It's causing failures in Button_a11y.html. But it happens on IE8 too, depending on how fast the user presses and releases the key.

Change History (2)

comment:1 Changed 8 years ago by bill

Resolution: duplicate
Status: newclosed

I'll handle this as part of #12696. Now I'm not so sure if my description above is correct, or if the problem only occurs on key repeat.

comment:2 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.