Opened 8 years ago

Closed 8 years ago

#12663 closed defect (fixed)

Rhino Build includes Browser specific modules

Reported by: zet4080 Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

Download src release of dojo 1.6

Go to util/buildscripts

build profile=rhino action=release

The build includes browser specific modules like _base/html.js and some more.

Change History (5)

comment:1 Changed 8 years ago by zet4080

I tracked the error down to util/buildscripts/jslib/fileUtil.js, Method transformAsyncModule.

At the very beginning of this method are some variable definitions, and there is the line

dojo = { isBrowser:true },

included.

If I set this value to false the build is done as expected (means: like in Version 1.5.0).

It is not the correct place to do this, because if I run the base.profile.js now, the Browser parts are missing, so I guess it is not the right place to set the isBrowser property at all, but I can't figure out what the right place is ...

comment:2 Changed 8 years ago by Rawld Gill

Milestone: tbd1.7
Status: newassigned

comment:3 Changed 8 years ago by Rawld Gill

Status: assignednew

comment:4 Changed 8 years ago by Rawld Gill

Status: newassigned

comment:5 Changed 8 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

This is a duplicate of #12648. It is fixed in [25189].

Note: See TracTickets for help on using tickets.