Opened 9 years ago

Closed 9 years ago

#12662 closed defect (fixed)

Resizing on orientationchange does not work correctly on Android

Reported by: ykami Owned by: ykami
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.6.0
Keywords: 1.7-mobile Cc:
Blocked By: Blocking:

Description

When the orientation change on Android (at least 2.x) the orientchange event is a send a bit early at a point in time where the computation of the margin/contentBox of a node will still take the "old" size into account not the size after orientation change.

You can reproduce it without charting on the test_iPhone-TabBar-seg.html test (runned on Android). Just rotate the device back and forth and you will see the TabBar buttons are not correctly aligned. This is because of contentBox not being ok when orientationchange is fired.

Change History (2)

comment:1 Changed 9 years ago by ykami

The workaround is to listen to resize event instead of orientationchange event. When resize is fired the size seems to be correctly computed.

comment:2 Changed 9 years ago by ykami

Resolution: fixed
Status: newclosed

(In [24307]) Fixes #12662 !strict. On Android, listen to onresize instead of onorientationchange

Note: See TracTickets for help on using tickets.