Opened 9 years ago

Closed 9 years ago

#12648 closed defect (fixed)

build for profile "rhino" does not work correctly

Reported by: zet4080 Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

Download src release of dojo 1.6

Go to util/buildscripts

build profile=rhino action=release

The build is done without error. Look into /release/dojo/dojo/build.txt

Line 7 in this file is:

./../../dojo/_base/_loader/hostenv_browser.js

but should be

./../../dojo/_base/_loader/hostenv_rhino.js

Attachments (1)

buildUtil.js (75.8 KB) - added by zet4080 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by zet4080

Attachment: buildUtil.js added

comment:1 Changed 9 years ago by zet4080

The problem is in util/buildscripts/jslib/buildUtil.js

With 1.6.0 the Method buildUtil.evalProfile is split up in two methods:

buildUtil.evalProfile buildUtil.processProfile

In evalProfile the profile is evaluated and so the hostenvType variable is set there. But only the dependencies are given to processProfile, so hostenvType is lost.

I attached a buildUtil.js that works for me, but: buildUtil.processProfile is called twice and I didn't understand exactly what happens in buildUtil.makeBuildOptions, so I can't decide if its missing there, too.

comment:2 Changed 9 years ago by Rawld Gill

Milestone: 1.7
Status: newassigned

comment:3 Changed 9 years ago by Rawld Gill

Resolution: fixed
Status: assignedclosed

(In [25189]) updated rhino profile for compat with new build system; fixes #12648

Note: See TracTickets for help on using tickets.