Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12628 closed defect (fixed)

dijit.form.DateTextBox does not fire onChange when selecting today's date

Reported by: ben hockey Owned by: Douglas Hays
Priority: high Milestone: 1.6.1
Component: Dijit - Form Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

the simplest way to demonstrate this is to use dijit/tests/form/test_DateTextBox.html and change the first DateTextBox? so that it has no value when it is created.

<input id="local" data-dojo-type="dijit.form.DateTextBox"
	data-dojo-props='name:"noDOMvalue", type:"text", onMouseEnter:eventHandler,
	onMouseLeave:eventHandler,
	onKeyDown:eventHandler,
	onChange:function(val){ dojo.byId("oc1").value = "" + val; }
'/>

select today's date from the dropdown and you'll see onChange: "not fired yet!"

Change History (4)

comment:1 Changed 8 years ago by ben hockey

fyi - this is a regression from 1.5 behavior

comment:2 Changed 8 years ago by Douglas Hays

Milestone: tbd1.6.1

seems to be caused by [23332]

comment:3 Changed 8 years ago by Douglas Hays

Resolution: fixed
Status: newclosed

(In [24249]) Fixes #12628. Move _set code that checks for invalid dates to compare so it'll be used by onChange.

comment:4 Changed 8 years ago by Douglas Hays

(In [24250]) Refs #12628. Backport [24249] to 1.6.1.

Note: See TracTickets for help on using tickets.