Opened 13 years ago

Closed 13 years ago

#1261 closed defect (invalid)

SortableTable parses column argument in wrong order

Reported by: dojo@… Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

The SortableTable? column arguments are parsed in a unlogic order. dataType for example is parsed at the near end, overwriting possible sortusing arguments that would allow sorting of html columns.

Change History (1)

comment:1 Changed 13 years ago by Tom Trenka

Resolution: invalid
Status: newclosed

This is not a bug; this was by design. Regardless of whether or not the column going to use a custom sorter, the widget needs to know if the column in question is markup-based or not. Overwriting the dataType is the worst way I can think of to accomplish this task.

Note: See TracTickets for help on using tickets.