Opened 9 years ago

Closed 8 years ago

#12608 closed defect (wontfix)

debugAtAllCosts broken/unsupported

Reported by: ben hockey Owned by:
Priority: high Milestone: tbd
Component: General Version: 1.6.0
Keywords: Cc: Rawld Gill, Kris Zyp
Blocked By: Blocking:

Change History (8)

comment:1 Changed 9 years ago by frode

I'm experiencing this issue as well, exactly as described in the second of your links:

http://dojo-toolkit.33424.n3.nabble.com/Dojo-1-6-0rc1-not-working-well-with-Firebug-td2683312.html

All I get in Firebug's script tab are the following:

js/myApp.js
js/dojotoolkit/dojo/_base.js
js/dojotoolkit/dojo/dojo.js
js/dojotoolkit/dojo/_base/_loader/bootstrap.js
js/dojotoolkit/dojo/_base/_loader/bootstrap.js/event/seq/1
...
js/dojotoolkit/dojo/_base/_loader/bootstrap.js/event/seq/123
js/dojotoolkit/dojo/_base/_loader/hostevn_browser.js
js/dojotoolkit/dojo/_base/_loader/loader.js

I'm using Dojo 1.6.0, FF 4.0 and Firebug 1.7.0. Running "console.debug(dojo.config)" in Firebug's console confirms that debugAtAllCosts is true.

The above thread suggests disabling Firebugs's "Decompile for eval() source" to see the individual files in Firebugs script tab, however that option is removed in Firebug 1.7.0.

comment:2 Changed 9 years ago by ben hockey

you may be interested in watching this for a related firebug/firefox issue http://code.google.com/p/fbug/issues/detail?id=4289

it seems the current recommendation is to go back to ff 3.6 and fb 1.7 (see comment 8 on that ticket)

comment:3 Changed 9 years ago by frode

The issue is further discussed here http://code.google.com/p/fbug/issues/detail?id=4035

comment:4 in reply to:  2 Changed 9 years ago by frode

Replying to neonstalwart:

you may be interested in watching this for a related firebug/firefox issue http://code.google.com/p/fbug/issues/detail?id=4289

it seems the current recommendation is to go back to ff 3.6 and fb 1.7 (see comment 8 on that ticket)

Thanks. Disregard my previous comment, I didn't notice you had posted in the meantime.

comment:5 Changed 9 years ago by davija

Any feedback from any of the dojo devs on this? This is a roadblock for me with dojo at this point in time.

comment:6 Changed 8 years ago by Douglas Hays

It seems debugAtAllCosts is needed to debug IE8 problems but it's not working starting with 1.6. Any resolution on this?

comment:7 Changed 8 years ago by ben hockey

this is the latest info i have http://comments.gmane.org/gmane.comp.web.dojo.user/55416

summary... it was broken during development of 1.6, it's not needed in 1.7 (use async loading instead) and it doesn't seem there were any objections to not fixing it in 1.6. i personally have no need for debugAtAllCosts but i'm surprised there was no reaction to the post linked to above.

comment:8 Changed 8 years ago by bill

Resolution: wontfix
Status: newclosed

Also listed in #13102 and http://docs.dojocampus.org/releasenotes/1.7 as being unsupported.

Note: See TracTickets for help on using tickets.