Opened 9 years ago

Closed 8 years ago

#12602 closed defect (wontfix)

width of enhancedgrid column in chrome error

Reported by: fabioginzel Owned by: Evan
Priority: high Milestone: 1.8
Component: DojoX Grid Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

If set width of column in px the result is minus

see image

sorry about my english

Attachments (3)

teste.JPG (139.2 KB) - added by fabioginzel 9 years ago.
52.png (203.3 KB) - added by fabioginzel 8 years ago.
45.png (189.4 KB) - added by fabioginzel 8 years ago.

Download all attachments as: .zip

Change History (14)

Changed 9 years ago by fabioginzel

Attachment: teste.JPG added

comment:1 Changed 9 years ago by evan

Milestone: tbd1.7
Priority: normalhigh

comment:2 Changed 9 years ago by evan

Hi fabioginzel,

I was not able to reproduce this(minus width) in either trunk or 1.6, can you post a test case?

comment:3 Changed 8 years ago by evan

Resolution: worksforme
Status: newclosed

We can reopen this once got a test case for reproducing.

comment:4 Changed 8 years ago by fabioginzel

Resolution: worksforme
Status: closedreopened

Set width of column and open with google chrome. See real width with dev tool.

comment:5 Changed 8 years ago by Adam Peller

Milestone: 1.71.7.1

comment:6 Changed 8 years ago by Evan

Just had a quick try with test_enhanced_grid_cellmerge.html in 1.6 code base, didn't see the issue after changing column 'Genre' width to '200px'.

Can you post a test case to reproduce this?

Thanks!

Changed 8 years ago by fabioginzel

Attachment: 52.png added

comment:7 Changed 8 years ago by fabioginzel

I open test_enhanced_grid_cellmerge.html and change width of genre to 100px.. but real width is 88px.

Changed 8 years ago by fabioginzel

Attachment: 45.png added

comment:8 Changed 8 years ago by fabioginzel

You can se the diference in chrome vs Firefox

comment:9 Changed 8 years ago by Adam Peller

Milestone: 1.7.11.8

comment:10 Changed 8 years ago by Douglas Hays

Owner: changed from evan to Evan
Status: reopenednew

comment:11 Changed 8 years ago by Evan

Resolution: wontfix
Status: newclosed

Actually, this is a browser specific behavior - border, padding are also included in the total width in Chrome, so in that case you got

100 px(original setting) = 88px(real width) + 2 * 5px(left/right padding) + 2 * 1px(left/right border)

This is a generic across all Grid types - Grid column width is not 100% accurately same across browsers due to different browser box-model calculations(or even on %, em, px etc.) But adding this kind of normalization in Grid will affect rendering speed, so closing this as won't fix.

Note: See TracTickets for help on using tickets.