Opened 9 years ago

Closed 8 years ago

#12578 closed defect (fixed)

dojox.grid.enhanced._Events bug

Reported by: patrickzope Owned by: evan
Priority: high Milestone: 1.7
Component: DojoX Grid Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

The constructor for dojox.grid.enhanced._Events contains the following code:

for(var p in this._events){
    if(!this[p]){
        this.p = this._events.p;
    }
}

Surely this is not the intended behavior (assigning the non-existent "p" attribute of "this._events" to this.p).

Change History (5)

comment:1 Changed 9 years ago by bill

Component: GeneralDojoX Grid
Owner: set to evan

comment:2 Changed 8 years ago by evan

Milestone: tbd1.7
Resolution: invalid
Status: newclosed

Hi Patrick,

The logic should be correct - it intends to iterate this._events and copy properties into 'this'(if the properties are missed in 'this').

I'm closing it, please reopen if you've noticed any error observations on test cases.

Thanks!

comment:3 Changed 8 years ago by patrickzope

Resolution: invalid
Status: closedreopened

The code is incorrect.

If intended behavior is as you described, it should look like:

for(var p in this._events){
    if(!this[p]){
        this[p] = this._events[p];
    }
}

comment:4 Changed 8 years ago by evan

Oh, yep, should have taken a more close look, thanks, Patrick! I'll also remove that block since it seems to be obsolete.

comment:5 Changed 8 years ago by evan

Resolution: fixed
Status: reopenedclosed

(In [25479]) Fixes #12578 by removing obsolete lines

Note: See TracTickets for help on using tickets.