Opened 8 years ago

Closed 3 years ago

#12574 closed enhancement (patchwelcome)

Can we put the 'src' release of Dojo into the Maven repos please

Reported by: andy Owned by: Greg Wilkins
Priority: low Milestone: 1.11
Component: BuildSystem Version: 1.6.0
Keywords: maven source repo reviewed Cc:
Blocked By: Blocking:

Description

When a new version of Dojo is released, the maven repo is updated with the new version. However, only the standard Dojo build is uploaded. Would it be possible to also upload the 'src' build as well? This would be really useful for anyone who needs the src build (e.g. to do custom builds) and uses Maven. Currently, the workaround I have is to download the src build from the download page, do the checksum check and then install the source build to all our local repos manually.

Change History (9)

comment:1 Changed 8 years ago by Adam Peller

Component: GeneralBuildSystem
Owner: set to gregwilkins

comment:2 Changed 8 years ago by Chris Mitchell

Owner: changed from gregwilkins to dylan

comment:3 Changed 7 years ago by dylan

Keywords: reviewed added
Priority: highlow
Status: newassigned

Email sent to Greg Wilkins seeing if he can set this up for us.

comment:4 Changed 7 years ago by dylan

Owner: changed from dylan to Greg Wilkins

Discussed with Greg Wilkins, he's looking into it.

comment:5 Changed 6 years ago by Kitson Kelly

#15120 is a duplicate of this ticket.

comment:6 Changed 6 years ago by Kitson Kelly

Resolution: duplicate
Status: assignedclosed

Duplicate of #12123.

comment:7 Changed 6 years ago by Matt Senter

This issue asks about putting the dojo sources into Maven, but it was closed as a duplicate of a "fixed" issue that doesn't seem to have put the sources into Maven. At least, I don't see the source builds in Maven. Example:

http://repo1.maven.org/maven2/org/dojotoolkit/dojo/1.9.0/

Though those archives contain both compressed and uncompressed files, I don't believe it's compatible with something such as the standard build util. Are there any plans to distribute JUST a sources archive for each version? It would be incredibly useful for maven users.

comment:8 Changed 6 years ago by Greg Wilkins

Resolution: duplicate
Status: closedreopened

I think having source in the maven reop would be great. However I have zero time to actually work on that.

But if you wanted to contribute some changes to the dojo-maven poms that generated source artefacts then I'd be happy to review and commit those changes.

comment:9 Changed 3 years ago by dylan

Milestone: tbd1.11
Resolution: patchwelcome
Status: reopenedclosed

If someone wants to take over the efforts to put Dojo releases into maven, please let us know!

Note: See TracTickets for help on using tickets.