Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12571 closed defect (fixed)

EnhancedGrid - inconsistent selection state when selectionMode="single"

Reported by: evan Owned by: evan
Priority: high Milestone: 1.6.1
Component: DojoX Grid Version: 1.6.0
Keywords: edg, selection Cc:
Blocked By: Blocking:

Description

This issue only occurs when EDG is selectionMode="single", Selector and IndirectSelection? are both turned on.

Steps to reproduce:
1.Open the attached test case
2.Select a row by clicking the radio box
3.Deselect the row by clicking the radio box again
4.Repeat step2, step3
5.The inconsistent selection state occurs

Attachments (2)

12571.html (4.6 KB) - added by evan 8 years ago.
12571.jpg (27.5 KB) - added by evan 8 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by evan

Attachment: 12571.html added

Changed 8 years ago by evan

Attachment: 12571.jpg added

comment:1 Changed 8 years ago by evan

Resolution: fixed
Status: newclosed

(In [24159]) Fixes #12571, caused by a conflict checking in Selector plugin, thanks for the patch from Oliver(IBM, CCLA), !strict

comment:2 Changed 8 years ago by evan

Milestone: tbd1.6.1

comment:3 Changed 8 years ago by evan

(In [24160]) Roll back [24159] with correct fix, refs #12571, !strict

comment:4 Changed 8 years ago by evan

(In [24271]) Refs #12571 !strict, add missed sane check for node toggleClass, applied both to trunk and 1.6 branch

comment:5 Changed 8 years ago by evan

(In [25674]) Refs #12571 !strict when selector and indirectSelection both turned on, the parameter plugins:{selector:{noClear:true}} can make sure selections are not mutual affected.

comment:6 Changed 8 years ago by evan

(In [25815]) Refs #12571 !strict adding missed condition when selectionMode = 'single'

comment:7 Changed 8 years ago by evan

(In [25822]) Refs #12571 !strict when selectionMode = 'single', we only clear row selections if selector.noClear = true

comment:8 Changed 8 years ago by evan

(In [25829]) Refs #12571 !strict use the clean way to clear selections

comment:9 Changed 8 years ago by evan

(In [25869]) Refs #12571 !strict noClear shouldn't affect column/cell selection

Note: See TracTickets for help on using tickets.