Opened 10 years ago

Closed 10 years ago

#12556 closed defect (fixed)

[regression] dojox.editor.plugins.LocalImage does not work

Reported by: youngho Owned by: Gu Yi, He
Priority: high Milestone: 1.7
Component: Editor Version: 1.6.0
Keywords: editor localImage Cc:
Blocked By: Blocking:

Description

Hello,

Go to the http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/editor/tests/editorLocalImage.html

and click the localImage plugin button. Than the plugin dropdown dialog show.

Select the upload file, than the dropdown dialog disappear before insert button click.

Attachments (1)

LocalImage.patch (1.1 KB) - added by Adam Peller 10 years ago.
patch from Eldon (IBM, CCLA)

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by youngho

I tested with FF on Windows it worked well before for example http://archive.dojotoolkit.org/dojo-2011-03-10/dojotoolkit/dojox/editor/tests/editorLocalImage.html with FF, it worked well.

comment:2 Changed 10 years ago by youngho

2011-03-25 version works without any problem with FF. But 2011-03-26 version doent not work with FF.

Problably 2011-03-26 changes may have some side effect for this behavior.

comment:3 Changed 10 years ago by Adam Peller

Milestone: tbd1.6.1
Owner: set to Gu Yi, He

comment:4 Changed 10 years ago by Adam Peller

Resolution: fixed
Status: newclosed

(In [24217]) patch from Eldon, fixes #12556 \!strict

comment:5 Changed 10 years ago by Adam Peller

(In [24218]) patch from Eldon, applied to 1.6 branch. Fixes #12556 \!strict

comment:6 Changed 10 years ago by William Riley

Resolution: fixed
Status: closedreopened

I'm finding this is happening in Firefox 5 now. It still works in Chrome though. I'm finding this is happening in Dojo 1.7.0b2. FWIW, I'm using Ubuntu.

comment:7 Changed 10 years ago by Adam Peller

Milestone: 1.6.11.7

Putting in 1.7 queue so it won't get lost. Need to look at whether another patch should be made to 1.6 as well.

Changed 10 years ago by Adam Peller

Attachment: LocalImage.patch added

patch from Eldon (IBM, CCLA)

comment:8 Changed 10 years ago by William Riley

I can confirm that this patch fixes the regression

comment:9 in reply to:  8 Changed 10 years ago by Adam Peller

Resolution: fixed
Status: reopenedclosed

Replying to psychcf:

I can confirm that this patch fixes the regression

Looks like trac is still missing things... I checked in Eldon's patch in [25991] Please test and let me know if there are any problems. Thanks

Note: See TracTickets for help on using tickets.