Opened 9 years ago

Last modified 3 years ago

#12548 assigned defect

[patch][ccla]Chart: Legend is not ordered correctly with Clustered Horizontal Bar chart

Reported by: ruanqi Owned by: cjolif
Priority: high Milestone: 1.15
Component: Charting Version: 1.6.0
Keywords: legend order, visually Cc: rqruanqi@…
Blocked By: Blocking:

Description

(1) Use dojox.charting.widget.Legend to add legend to Clustered Horizontal Bar Chart.

(2) The visually order of legend is not correct, the legend show with a reversed order of the bars.

Please look at the attached charting image.

Attachments (4)

Legend-Order-Issue.JPG (27.5 KB) - added by ruanqi 9 years ago.
the legend order is not the same as the bars
legend-order.patch (937 bytes) - added by Adam Peller 9 years ago.
updated patch from Rock (IBM, CCLA) The _isReversal function in the patch will determine whether the legends have to be reversed.
legend-reversed-reintroduced.png (16.4 KB) - added by stephend 6 years ago.
Legend.js.patch (352 bytes) - added by stephend 6 years ago.

Download all attachments as: .zip

Change History (13)

Changed 9 years ago by ruanqi

Attachment: Legend-Order-Issue.JPG added

the legend order is not the same as the bars

Changed 9 years ago by Adam Peller

Attachment: legend-order.patch added

updated patch from Rock (IBM, CCLA) The _isReversal function in the patch will determine whether the legends have to be reversed.

comment:1 Changed 9 years ago by Eugene Lazutkin

Resolution: fixed
Status: newclosed

(In [25004]) charting: reversed order of series for some stacked and clustered plots, thx Rock (IBM, CCLA)!, !strict, fixes #12548.

comment:2 Changed 8 years ago by Douglas Hays

(In [25738]) Refs #12548. Forgot to clone array before reverse label traversal.

Changed 6 years ago by stephend

comment:3 Changed 6 years ago by stephend

This issue seems to have been reintroduced in 1.8. It applies to other chart types, including vertical ones like StackedArea?.

Changed 6 years ago by stephend

Attachment: Legend.js.patch added

comment:4 Changed 6 years ago by cjolif

stephend do you have CLA on file? (http://dojofoundation.org/about/cla)

If not can you please sign it so we can apply your patch?

comment:5 Changed 6 years ago by cjolif

Milestone: 1.7
Resolution: fixed
Status: closedreopened

I guess what people want to see is arguable in particular for stack charts. What is sure is that we can't apply the "reserve" to all type of charts (for example ClusteredColumns? show no issue?). So your patch can't be applied as-is and something more similar to what was there before would make more sense?

comment:6 Changed 6 years ago by cjolif

#17793 is a duplicate of this ticket.

comment:7 Changed 6 years ago by cjolif

Owner: changed from Eugene Lazutkin to cjolif
Status: reopenedassigned

comment:8 Changed 4 years ago by dylan

Milestone: 1.12

comment:9 Changed 3 years ago by dylan

Milestone: 1.131.15

Ticket planning... move current 1.13 tickets out to 1.15 to make it easier to move tickets into the 1.13 milestone.

Note: See TracTickets for help on using tickets.