Opened 9 years ago

Closed 8 years ago

#12535 closed defect (wontfix)

build process renamespacing of dojo1.6 causes an error within the generated dojo.js

Reported by: Werner Punz Owned by: Rawld Gill
Priority: high Milestone: 1.7
Component: BuildSystem Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

please see http://old.nabble.com/dojo-1.6-weird-problem-if-I-try-to-call-dojo-query-%28dojo.query-does-not-exist%29-td31171480.html#a31181315 for the entire details.

Just to give a short summary, I do a renamespacing of the dojo namespace via my build process ./build.sh loader=xdomain profile=standard action=release releaseName=dojo_custom_ns releaseDir=../../../dojo_custom_ns scopeMap=\"dojo\",\"dojo_custom_ns\"],[\"dijit\",\"dijit_custom_ns\"],[\"dojox\",\"dojox_custom_ns\"? and i am getting following error later on when i include the generated dojo.js and then during onLoad call dojo_custom_ns.query: "dojo.query does not exist". The reason for this issue is a namespace issue, which is further detailed in the link above.

The issue is newly introduced in 1.6, it used to work in 1.5.

Change History (5)

comment:1 Changed 9 years ago by bill

Owner: changed from James Burke to Rawld Gill

comment:2 Changed 9 years ago by Rawld Gill

Status: newassigned

comment:3 Changed 9 years ago by Rawld Gill

Milestone: tbd1.7
Priority: normalhigh
severity: majornormal

comment:4 Changed 9 years ago by rlintern

We also just upgraded to Dojo 1.6 and also experiencing this same issue. Is there a workaround? Dojo 1.7 is too far away for us at the moment.

comment:5 Changed 8 years ago by Rawld Gill

Resolution: wontfix
Status: assignedclosed

See http://mail.dojotoolkit.org/pipermail/dojo-interest/2011-August/057123.html for an explanation of this issue. It won't be fixed in 1.6.x (but can be fixed locally) It's not an issue in 1.7.

Note: See TracTickets for help on using tickets.