Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#12531 closed defect (fixed)

[regression] Toolbar: focus border on buttons not visible (IE)

Reported by: bill Owned by: bill
Priority: high Milestone: 1.6.1
Component: Dijit - Form Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

See test_Toolbar.html on IE (tested on IE9 but reportedly happens on IE8 too). If you tab into the toolbar and use left/right arrow keys you cannot see the focus outline on the buttons.

Change History (3)

comment:1 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [24102]) Fix problem on Toolbar buttons where IE doesn't display focus border (after tabbing into the toolbar, or using the arrow keys to navigate).

IE doesn't display focus border if you focus() a node with tabIndex=-1. Thus, fixing problem by setting the button's tabIndex to 0 before focusing the node.

This problem didn't occur in 1.5 because after focusing the node, _KeyNavContainer set the node's tabindex to 0 and then bumped the node by setting node.className in _CssStateMixin._setStateClass() But, after [23228] _KeyNavContainer's _onFocus advice runs after _CssStateMixin's _setStateClass() call (triggered by the watch() on "focused".

Refs #10272, fixes #12531 on trunk, !strict

comment:2 Changed 9 years ago by bill

(In [24103]) Fix problem on Toolbar buttons where IE doesn't display focus border (after tabbing into the toolbar, or using the arrow keys to navigate).

Refs #10272, fixes #12531 on 1.6/ branch, !strict

comment:3 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.