Opened 8 years ago

Closed 8 years ago

#12518 closed defect (invalid)

node.nodeType Failing in IE9

Reported by: Fergus Hadley Owned by: sjmiles
Priority: high Milestone: tbd
Component: HTML Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

I am getting this error in IE9:

SCRIPT5007: Unable to get value of the property 'nodeType': object is null or undefined 
dojo.xd.js.uncompressed.js, line 6297 character 4

I'm afraid I can't trace the line causing the error as IE doesn't offer a stack trace.

Change History (3)

comment:1 Changed 8 years ago by Fergus Hadley

The line in dojo.js is this:

else if(d.isIE){
		gcs = function(node){
			// IE (as of 7) doesn't expose Element like sane browsers
			return node.nodeType == 1 /* ELEMENT_NODE*/ ? node.currentStyle : {}; // <-- this line!
		};

comment:2 Changed 8 years ago by bill

Component: GeneralHTML
Owner: set to sjmiles

You need to give steps to reproduce the problem, either attaching a test case or steps against one of our existing test cases.

comment:3 Changed 8 years ago by bill

Resolution: invalid
Status: newclosed

Closing due to lack of test case / steps to reproduce.

Note: See TracTickets for help on using tickets.