Opened 8 years ago

Closed 8 years ago

#12503 closed defect (duplicate)

Many failures in dijit.tests.form.robot.FormState on ff4

Reported by: Chris Mitchell Owned by: Douglas Hays
Priority: high Milestone: 1.6.1
Component: Dijit - Form Version: 1.6.0
Keywords: ff4 Cc:
Blocked By: Blocking:

Description

GROUP "dijit.tests.form.robot.FormState?" has 1 test to run

9 tests to run in 1 groups ------------------------------------------------------------ GROUP "FormValidationState?" has 9 tests to run TypeError?: dijit.byId is not a function

ERROR IN:

(function () {doh.t(dijit.byId("submitButton").get("disabled"));})

FAILED test: ../../dijit/tests/form/robot/Form_state.html::FormValidationState::formLoadInvalid 0 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.sequence(function () {dojo.byId("notes").focus();});doh.robot.typeKeys("my notes", 1, 1200);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("submitButton").get("disabled"));}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/Form_state.html::FormValidationState::initialFormInvalid 2202 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.sequence(function () {dojo.byId("name").focus();});doh.robot.typeKeys("my name", 1, 1000);doh.robot.sequence(function () {dojo.byId("birth").focus();dijit.byId("birth").set("value", null);}, 500);doh.robot.typeKeys("1/1/2010", 1, 1200);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("submitButton").get("disabled"));}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/Form_state.html::FormValidationState::initialFormInvalid2 3704 ms TypeError?: dojo.byId("reset") is null

ERROR IN:

(function () {var d = new doh.Deferred;dojo.byId("reset").focus();dojo.byId("reset").click();setTimeout(d.getTestCallback(function () {doh.f(dijit.byId("submitButton").get("disabled"));}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/Form_state.html::FormValidationState::initialFormValid 0 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.sequence(function () {dojo.byId("birth").focus();dijit.byId("birth").set("value", null);});doh.robot.typeKeys("1/1/2010", 1, 1200);doh.robot.sequence(function () {dojo.byId("disable").focus();dojo.byId("disable").click();}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("submitButton").get("disabled"));}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/Form_state.html::FormValidationState::initialFormValid2 2701 ms TypeError?: dojo.byId("enable") is null

ERROR IN:

(function () {var d = new doh.Deferred;dojo.byId("enable").focus();dojo.byId("enable").click();setTimeout(d.getTestCallback(function () {doh.t(dijit.byId("submitButton").get("disabled"));}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/Form_state.html::FormValidationState::initialFormInvalid3 0 ms TypeError?: dojo.byId("reset") is null

ERROR IN:

(function () {var d = new doh.Deferred;dojo.byId("reset").focus();dojo.byId("reset").click();dojo.byId("addMoreFields").focus();dijit.byId("addMoreFields").onClick();setTimeout(d.getTestCallback(function () {doh.t(dijit.byId("submitButton").get("disabled"));}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/Form_state.html::FormValidationState::moreFieldsInvalid 0 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.sequence(function () {dojo.byId("lastName").focus();});doh.robot.typeKeys("my last name", 1, 1800);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("submitButton").get("disabled"));}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/Form_state.html::FormValidationState::moreFieldsValid 2800 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.sequence(function () {dojo.byId("color").focus();dijit.byId("color").set("value", null);});doh.robot.keyPress(dojo.keys.TAB, 1, {});doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("submitButton").get("disabled"));}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/Form_state.html::FormValidationState::moreFieldsInvalid2 1004 ms PASSED test: ../../dijit/tests/form/robot/Form_state.html 13376 ms

Change History (2)

comment:1 Changed 8 years ago by bill

Hmm, it works for me, I just ran the test standalone against FF4 final, and I've run the full regression suite against FF4 RC.

comment:2 Changed 8 years ago by Douglas Hays

Milestone: tbd1.6.1
Resolution: duplicate
Status: newclosed

Seems to be a dup of #12502 where dijit.byId is not setup correctly by the robot.

Note: See TracTickets for help on using tickets.