Opened 9 years ago

Closed 9 years ago

#12502 closed defect (worksforme)

Many failures in dijit.tests.form.robot.CheckBox_a11y on ff4

Reported by: Chris Mitchell Owned by: Douglas Hays
Priority: high Milestone: 1.6.1
Component: Dijit - Form Version: 1.6.0
Keywords: ff4 Cc: haysmark
Blocked By: Blocking:

Description

GROUP "dijit.tests.form.robot.CheckBox_a11y" has 1 test to run

17 tests to run in 3 groups ------------------------------------------------------------ GROUP "Checkbox a11y" has 6 tests to run TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;dijit.byId("cb1").focus();doh.robot.keyPress(dojo.keys.TAB, 500, {shift: true});doh.robot.keyPress(dojo.keys.SPACE, 1000);doh.robot.sequence(d.getTestCallback(function () {doh.f(dojo.byId("cb0").checked, "cb0 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Checkbox a11y::uncheck cb0 a11y 0 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.TAB, 500);doh.robot.keyPress(dojo.keys.SPACE, 1000);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("cb1").checked, "cb1 was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Checkbox a11y::check cb1 a11y 2500 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.TAB, 500);doh.robot.keyPress(dojo.keys.TAB, 1000);doh.robot.keyPress(dojo.keys.SPACE, 1000);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("cb2").checked, "cb2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Checkbox a11y::uncheck cb2 a11y 3501 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.TAB, 500);doh.robot.keyPress(dojo.keys.TAB, 1000);doh.robot.keyPress(dojo.keys.SPACE, 1000);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("cb4").checked, "cb4 was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Checkbox a11y::cb4 readonly a11y 3501 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.TAB, 500);doh.robot.keyPress(dojo.keys.TAB, 1000);doh.robot.keyPress(dojo.keys.TAB, 1000);doh.robot.keyPress(dojo.keys.SPACE, 1000);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("cb6").checked, "cb6 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Checkbox a11y::cb6 uncheck a11y 4500 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.SPACE, 500);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("cb6").checked, "cb6 was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Checkbox a11y::cb6 check a11y 1500 ms ------------------------------------------------------------ GROUP "Radio button a11y" has 10 tests to run TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;dijit.byId("g1rb2").focus();dijit.byId("g1rb3").set("disabled", false);doh.robot.keyPress(dojo.keys.RIGHT_ARROW, 1000);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("g1rb1").checked, "news was checked");doh.f(dijit.byId("g1rb2").checked, "talk was checked");doh.t(dijit.byId("g1rb3").checked, "weather was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Radio button a11y::weather enabled a11y 0 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;dijit.byId("g2rb1").focus();doh.robot.keyPress(dojo.keys.RIGHT_ARROW, 1000);doh.robot.keyPress(dojo.keys.DOWN_ARROW, 500);doh.robot.keyPress(dojo.keys.SPACE, 500);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("g2rb3").checked, "country was not checked");doh.f(dijit.byId("g2rb2").checked, "oldies was checked");doh.f(dijit.byId("g2rb1").checked, "top 40 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Radio button a11y::change value to county a11y 0 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.UP_ARROW, 500);doh.robot.keyPress(dojo.keys.LEFT_ARROW, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("g2rb3").checked, "country was checked");doh.f(dijit.byId("g2rb2").checked, "oldies was checked");doh.t(dijit.byId("g2rb1").checked, "top 40 was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Radio button a11y::change value to top 40 a11y 2000 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.TAB, 500);doh.robot.keyPress(dojo.keys.TAB, 1000);doh.robot.keyPress(dojo.keys.TAB, 1000);doh.robot.keyPress(dojo.keys.TAB, 1000);doh.robot.keyPress(dojo.keys.SPACE, 1000);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("b1").checked, "b1 was not checked");doh.f(dijit.byId("b2").checked, "b2 was checked");doh.f(dijit.byId("c1").checked, "c1 was checked");doh.f(dijit.byId("c2").checked, "c2 was checked");doh.f(dijit.byId("d1").checked, "d1 was checked");doh.f(dijit.byId("d2").checked, "d2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Radio button a11y::enable b1 a11y 5500 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.DOWN_ARROW, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("b1").checked, "b1 was checked");doh.t(dijit.byId("b2").checked, "b2 was not checked");doh.f(dijit.byId("c1").checked, "c1 was checked");doh.f(dijit.byId("c2").checked, "c2 was checked");doh.f(dijit.byId("d1").checked, "d1 was checked");doh.f(dijit.byId("d2").checked, "d2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Radio button a11y::enable b2 a11y 1500 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.TAB, 500);doh.robot.keyPress(dojo.keys.SPACE, 1000);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("b1").checked, "b1 was checked");doh.t(dijit.byId("b2").checked, "b2 was not checked");doh.t(dijit.byId("c1").checked, "c1 was not checked");doh.f(dijit.byId("c2").checked, "c2 was checked");doh.f(dijit.byId("d1").checked, "d1 was checked");doh.f(dijit.byId("d2").checked, "d2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Radio button a11y::enable c1 a11y 2501 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.RIGHT_ARROW, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("b1").checked, "b1 was checked");doh.t(dijit.byId("b2").checked, "b2 was not checked");doh.f(dijit.byId("c1").checked, "c1 was checked");doh.t(dijit.byId("c2").checked, "c2 was not checked");doh.f(dijit.byId("d1").checked, "d1 was checked");doh.f(dijit.byId("d2").checked, "d2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Radio button a11y::enable c2 a11y 1500 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.TAB, 500);doh.robot.keyPress(dojo.keys.RIGHT_ARROW, 1000);doh.robot.keyPress(dojo.keys.SPACE, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("b1").checked, "b1 was checked");doh.t(dijit.byId("b2").checked, "b2 was not checked");doh.f(dijit.byId("c1").checked, "c1 was checked");doh.t(dijit.byId("c2").checked, "c2 was not checked");doh.f(dijit.byId("d1").checked, "d1 was checked");doh.t(dijit.byId("d2").checked, "d2 was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Radio button a11y::enable d2 a11y 3000 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.UP_ARROW, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("b1").checked, "b1 was checked");doh.t(dijit.byId("b2").checked, "b2 was not checked");doh.f(dijit.byId("c1").checked, "c1 was checked");doh.t(dijit.byId("c2").checked, "c2 was not checked");doh.t(dijit.byId("d1").checked, "d1 was not checked");doh.f(dijit.byId("d2").checked, "d2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Radio button a11y::enable d1 a11y 1501 ms TypeError?: dijit.byId is not a function

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.keyPress(dojo.keys.TAB, 500);doh.robot.keyPress(dojo.keys.DOWN_ARROW, 1000);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("g4rb1").checked, "tea was checked");doh.t(dijit.byId("g4rb2").checked, "coffee was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_a11y.html::Radio button a11y::enable coffee a11y 2500 ms ------------------------------------------------------------

Change History (3)

comment:1 Changed 9 years ago by Chris Mitchell

Summary: Many failures in dijit.tests.form.robot.CheckBox_a11yMany failures in dijit.tests.form.robot.CheckBox_a11y on ff4

comment:2 Changed 9 years ago by bill

Hmm, it works for me, I just ran the test standalone against FF4 final, and I've run the full regression suite against FF4 RC.

comment:3 Changed 9 years ago by Douglas Hays

Cc: haysmark added; ff4 removed
Keywords: ff4 added
Milestone: tbd1.6.1
Resolution: worksforme
Status: newclosed

I ran the test standalone on FF4 (final) on Windows/XP using Java 1.6.0_24-b07 and repeatedly got 0 failures. If this is still failing, please include both the OS and, especially important, the Java version as this seems likely to be a robot issue since the robot links the dijit.byId in the page with test commands to the actual dijit in the page being tested. Also it may be important to note if the failing test is being loaded as a separate URL or part of runTests.html.

Note: See TracTickets for help on using tickets.