Opened 9 years ago

Closed 9 years ago

#12501 closed defect (duplicate)

Many failures in dijit.tests.form.robot.CheckBox_mouse on ff4

Reported by: Chris Mitchell Owned by: Douglas Hays
Priority: high Milestone: 1.6.1
Component: Dijit - Form Version: 1.6.0
Keywords: Cc: ff4
Blocked By: Blocking:

Description

GROUP "dijit.tests.form.robot.CheckBox_mouse" has 1 test to run

24 tests to run in 5 groups ------------------------------------------------------------ GROUP "query input by checked state" has 1 test to run

_AssertFailure: http://archive.dojotoolkit.org/nightly/checkout/dojo/_base/_loader/bootstrap.js:585 doh._AssertFailure: assertEqual() failed:

expected 5 but got 0 with hint: expected: 5 checked widgets, got: 0

doh._AssertFailure

ERROR IN:

(function () {var queried = dojo.query("input[checked]", dojo.byId("myForm"));doh.is(5, queried.length, "expected: 5 checked widgets, got: " + queried.length);})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::query input by checked state::query checked 0 ms ------------------------------------------------------------ GROUP "query input by name" has 1 test to run

_AssertFailure: http://archive.dojotoolkit.org/nightly/checkout/dojo/_base/_loader/bootstrap.js:585 doh._AssertFailure: assertEqual() failed:

expected 13 but got 0 with hint: expected: 13 named widgets, got: 0

doh._AssertFailure

ERROR IN:

(function () {var queried = dojo.query("input[name]", dojo.byId("myForm"));doh.is(13, queried.length, "expected: 13 named widgets, got: " + queried.length);})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::query input by name::query name 0 ms ------------------------------------------------------------ GROUP "CheckBox? values" has 4 tests to run TypeError?: dojo.global.dojo is undefined

ERROR IN:

(function getValues() {doh.is(dojo.toJson(originalGet), dojo.global.dojo.toJson(dijit.byId("myForm").get("value")));})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::CheckBox? values::getValues 0 ms TypeError?: dojo.global.dojo is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.sequence(function () {submitForm("original submit", originalSubmit);}, 500);doh.robot.sequence(function () {dijit.byId("myForm").set("value", change);}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.is(dojo.toJson(changedGet), dojo.global.dojo.toJson(dijit.byId("myForm").get("value")));}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::CheckBox? values::setValues 1998 ms TypeError?: dojo.global.dojo is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.sequence(function () {submitForm("changed submit", changedSubmit);}, 500);doh.robot.sequence(function () {dijit.byId("myForm").reset();}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.is(dojo.toJson(originalGet), dojo.global.dojo.toJson(dijit.byId("myForm").get("value")), "reset to original values");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::CheckBox? values::resetValues 2001 ms TypeError?: dojo.global.dojo is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.sequence(function () {submitForm("reset submit", originalSubmit);}, 500);doh.robot.mouseMoveAt("cb4", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.is(dojo.toJson(originalGet), dojo.global.dojo.toJson(dijit.byId("myForm").get("value")), "still have original values");submitForm("resubmit", originalSubmit);}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::CheckBox? values::readOnly 2501 ms ------------------------------------------------------------ GROUP "CheckBox? onChange" has 2 tests to run TypeError?: dojo.byId("oncheckedoutput") is null

ERROR IN:

(function fireOnChange() {var d = new doh.Deferred;var cb = dijit.byId("cb2");var lastOnChange = dojo.byId("oncheckedoutput").innerHTML;cb.set("checked", !cb.get("checked"));setTimeout(d.getTestCallback(function () {doh.isNot(lastOnChange, dojo.byId("oncheckedoutput").innerHTML);}), 500);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::CheckBox? onChange::fireOnChange 0 ms TypeError?: dojo.byId("oncheckedoutput") is null

ERROR IN:

(function skipOnChange() {var d = new doh.Deferred;var cb = dijit.byId("cb2");var lastOnChange = dojo.byId("oncheckedoutput").innerHTML;cb.set("checked", !cb.get("checked"), false);setTimeout(d.getTestCallback(function () {doh.is(lastOnChange, dojo.byId("oncheckedoutput").innerHTML);}), 500);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::CheckBox? onChange::skipOnChange 0 ms ------------------------------------------------------------ GROUP "Radio button onChange" has 16 tests to run TypeError?: dijit.byId("g1rb1") is undefined

ERROR IN:

(function checkInitialValues() {doh.f(dijit.byId("g1rb1").checked, "news was checked");doh.t(dijit.byId("g1rb2").checked, "talk was not checked");doh.f(dijit.byId("g1rb3").checked, "weather was checked");doh.f(dijit.byId("g2rb1").checked, "top 40 was checked");doh.f(dijit.byId("g2rb2").checked, "oldies was checked");doh.f(dijit.byId("g2rb3").checked, "country was checked");doh.f(dojo.byId("g3rb1").checked, "rock was checked");doh.f(dojo.byId("g3rb2").checked, "jazz was checked");doh.t(dojo.byId("g3rb3").checked, "classical was not checked");doh.t(dijit.byId("g4rb1").checked, "tea was not checked");doh.f(dijit.byId("g4rb2").checked, "coffee was checked");})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::checkInitialValues 0 ms TypeError?: dijit.byId("g1rb1") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("g1rb1", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("g1rb1").checked, "news was not checked");doh.f(dijit.byId("g1rb2").checked, "talk was checked");doh.f(dijit.byId("g1rb3").checked, "weather was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::change value to news 2000 ms TypeError?: dijit.byId("g1rb1") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("g1rb3", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("g1rb1").checked, "news was not checked");doh.f(dijit.byId("g1rb2").checked, "talk was checked");doh.f(dijit.byId("g1rb3").checked, "weather was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::weather disabled 2003 ms TypeError?: dijit.byId("g1rb1") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("enableWeatherButton", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.mouseMoveAt("g1rb3", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("g1rb1").checked, "news was checked");doh.f(dijit.byId("g1rb2").checked, "talk was checked");doh.t(dijit.byId("g1rb3").checked, "weather was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::weather enabled 3004 ms TypeError?: dijit.byId("g2rb3") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("g2rb3", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("g2rb3").checked, "country was not checked");doh.f(dijit.byId("g2rb2").checked, "oldies was checked");doh.f(dijit.byId("g2rb1").checked, "top 40 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::change value to county 2002 ms TypeError?: dijit.byId("g2rb3") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("g2rb1", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("g2rb3").checked, "country was checked");doh.f(dijit.byId("g2rb2").checked, "oldies was checked");doh.t(dijit.byId("g2rb1").checked, "top 40 was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::change value to top 40 2003 ms TypeError?: dijit.byId("g2rb3") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("g2rb2", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("g2rb3").checked, "country was checked");doh.t(dijit.byId("g2rb2").checked, "oldies was not checked");doh.f(dijit.byId("g2rb1").checked, "top 40 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::change value to oldies 2001 ms TypeError?: dojo.byId("g3rb1") is null

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("g3rb1", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.t(dojo.byId("g3rb1").checked, "rock was not checked");doh.f(dojo.byId("g3rb2").checked, "jazz was checked");doh.f(dojo.byId("g3rb3").checked, "classical was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::change value to rock 2003 ms TypeError?: dojo.byId("g3rb1") is null

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("g3rb2", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.t(dojo.byId("g3rb1").checked, "rock was not checked");doh.f(dojo.byId("g3rb2").checked, "jazz was checked");doh.f(dojo.byId("g3rb3").checked, "classical was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::disabled jazz 2002 ms TypeError?: dijit.byId("b1") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("b1", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.t(dijit.byId("b1").checked, "b1 was not checked");doh.f(dijit.byId("b2").checked, "b2 was checked");doh.f(dijit.byId("c1").checked, "c1 was checked");doh.f(dijit.byId("c2").checked, "c2 was checked");doh.f(dijit.byId("d1").checked, "d1 was checked");doh.f(dijit.byId("d2").checked, "d2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::enable b1 2002 ms TypeError?: dijit.byId("b1") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("b2", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("b1").checked, "b1 was checked");doh.t(dijit.byId("b2").checked, "b2 was not checked");doh.f(dijit.byId("c1").checked, "c1 was checked");doh.f(dijit.byId("c2").checked, "c2 was checked");doh.f(dijit.byId("d1").checked, "d1 was checked");doh.f(dijit.byId("d2").checked, "d2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::enable b2 2002 ms TypeError?: dijit.byId("b1") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("c1", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("b1").checked, "b1 was checked");doh.t(dijit.byId("b2").checked, "b2 was not checked");doh.t(dijit.byId("c1").checked, "c1 was not checked");doh.f(dijit.byId("c2").checked, "c2 was checked");doh.f(dijit.byId("d1").checked, "d1 was checked");doh.f(dijit.byId("d2").checked, "d2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::enable c1 2002 ms TypeError?: dijit.byId("b1") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("c2", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("b1").checked, "b1 was checked");doh.t(dijit.byId("b2").checked, "b2 was not checked");doh.f(dijit.byId("c1").checked, "c1 was checked");doh.t(dijit.byId("c2").checked, "c2 was not checked");doh.f(dijit.byId("d1").checked, "d1 was checked");doh.f(dijit.byId("d2").checked, "d2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::enable c2 2002 ms TypeError?: dijit.byId("b1") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("d2", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("b1").checked, "b1 was checked");doh.t(dijit.byId("b2").checked, "b2 was not checked");doh.f(dijit.byId("c1").checked, "c1 was checked");doh.t(dijit.byId("c2").checked, "c2 was not checked");doh.f(dijit.byId("d1").checked, "d1 was checked");doh.t(dijit.byId("d2").checked, "d2 was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::enable d2 2002 ms TypeError?: dijit.byId("b1") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("d1", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("b1").checked, "b1 was checked");doh.t(dijit.byId("b2").checked, "b2 was not checked");doh.f(dijit.byId("c1").checked, "c1 was checked");doh.t(dijit.byId("c2").checked, "c2 was not checked");doh.t(dijit.byId("d1").checked, "d1 was not checked");doh.f(dijit.byId("d2").checked, "d2 was checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::enable d1 2002 ms TypeError?: dijit.byId("g4rb1") is undefined

ERROR IN:

(function () {var d = new doh.Deferred;doh.robot.mouseMoveAt("g4rb2", 500, 1);doh.robot.mouseClick({left: true}, 500);doh.robot.sequence(d.getTestCallback(function () {doh.f(dijit.byId("g4rb1").checked, "tea was checked");doh.t(dijit.byId("g4rb2").checked, "coffee was not checked");}), 1000);return d;})

FAILED test: ../../dijit/tests/form/robot/CheckBox_mouse.html::Radio button onChange::enable coffee 2002 ms PASSED test: ../../dijit/tests/form/robot/CheckBox_mouse.html 38559 ms

Change History (2)

comment:1 Changed 9 years ago by bill

Hmm, it works for me, I just ran the test standalone against FF4 final, and I've run the full regression suite against FF4 RC.

comment:2 Changed 9 years ago by Douglas Hays

Milestone: tbd1.6.1
Resolution: duplicate
Status: newclosed

This is working correctly for me as well. Seems to be a dup of #12502 where dijit.byId is not setup correctly by the robot.

Note: See TracTickets for help on using tickets.