Opened 10 years ago

Closed 10 years ago

#12496 closed defect (duplicate)

IE9: evt.charOrCode set incorrectly for ESCAPE key

Reported by: bill Owned by: sjmiles
Priority: high Milestone: 1.6.1
Component: Events Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

See test_TooltipDialog.html. Open first dialog and then press ESCAPE key to close the dialog. On IE9, it has no effect.

For dojo normalized events, evt.charOrCode should be set to 27 for the ESCAPE key. However, on IE9, it's set to a character instead. Thus our existing code that checks evt.charOrCode doesn't realize it's the ESCAPE key.

The problem is in event.js: _setKeyChar() depends on evt.charCode being 0/null/""/etc., but on IE9 it's a valid character.

Change History (1)

comment:1 Changed 10 years ago by bill

Resolution: duplicate
Status: newclosed

Got double-submitted, closing as dup of #12495.

Note: See TracTickets for help on using tickets.