Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12485 closed defect (fixed)

[patch][ccla]TabBar - CSS Size Definition on Icon is not Honored

Reported by: zhangyp Owned by: Chris Mitchell
Priority: high Milestone: 1.7
Component: DojoX Mobile Version: 1.6.0
Keywords: 1.7-mobile Cc: ccmitchellusa@…, drschwar@…, deanw@…, evanhuangwei@…, heguyi@…, rqruanqi@…, zhongsq@…, Evan
Blocked By: Blocking:

Description

This is a bug regarding the size of the icon in TabBar?. The CSS declaration of the height and width of the icon image is not honored. Thus, if the image original size exceeds the CSS size, sometimes the icon will show in its original size. Please see the attached picture. The root cause is the following statement which is supposed to fix a drawing issue in iPhone and Safari.

this.style.width = this.width + "px"; this.style.height = this.height + "px";

The problem is that if the size is specified through CSS, then it's "this.style.width" and "this.style.height". The above code won't work.

A possible way is to use the following statements.

var originDisplay = this.style.display; this.style.display = "none"; this.style.display = originDisplay;

Letting the icon hide and show seems to fix this problem.

Attachments (1)

Fix-TabBar-Icon-Size.patch (1.3 KB) - added by zhangyp 8 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 8 years ago by bill

Component: GeneralDojoX Mobile
Owner: changed from anonymous to ykami

Sounds like you are talking about dojox.mobile

comment:2 Changed 8 years ago by Chris Mitchell

Cc: ccmitchellusa@… drschwar@… deanw@… evanhuangwei@… heguyi@… rqruanqi@… zhongsq@… added
Keywords: 1.7-mobile added

this defect is a prereq for 12415 (mobile showcase)

comment:3 Changed 8 years ago by Chris Mitchell

Summary: TabBar - CSS Size Definition on Icon is not Honored[patch][ccla]TabBar - CSS Size Definition on Icon is not Honored

Changed 8 years ago by zhangyp

Attachment: Fix-TabBar-Icon-Size.patch added

comment:4 Changed 8 years ago by Chris Mitchell

Owner: changed from ykami to Chris Mitchell

comment:5 Changed 8 years ago by Chris Mitchell

Status: newassigned

comment:6 Changed 8 years ago by Chris Mitchell

Resolution: fixed
Status: assignedclosed

comment:7 Changed 8 years ago by Chris Mitchell

Milestone: tbd1.7

comment:8 Changed 8 years ago by Evan

Cc: Evan added
Note: See TracTickets for help on using tickets.