Opened 9 years ago

Closed 8 years ago

#12484 closed defect (duplicate)

ComboBox: apparently memory leak

Reported by: bill Owned by: bill
Priority: high Milestone: 1.8
Component: Dijit - Form Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

Starting in [9924] ComboBox.js does this:

menuitem.item=item;

where menuitem is a DOMNode and item is a JS object.

That's dangerous on IE, it will cause leaks when item points to a DOMNode, as is done by dijit.form.DataList, and some other data stores too IIRC.

I see that item is referenced from _announceOption() so we can't just remove it, but there should be some indirection so that the DOMNode just contains an id or index.

Change History (3)

comment:1 Changed 8 years ago by haysmark

Milestone: tbdfuture

comment:2 Changed 8 years ago by bill

Milestone: future1.8
Owner: changed from haysmark to bill
Status: newassigned

comment:3 Changed 8 years ago by bill

Resolution: duplicate
Status: assignedclosed

Duplicate of #15206.
Fixed in [28551].

Note: See TracTickets for help on using tickets.