Opened 8 years ago

Closed 6 years ago

#12479 closed defect (duplicate)

Dialog: clicking underlay then pressing tab focuses objects behind dialog

Reported by: vtsuper Owned by:
Priority: high Milestone: 1.6.2
Component: Dijit Version: 1.6.0
Keywords: dijit.dialog tab overlay Cc:
Blocked By: Blocking:

Description

According to this example http://download.dojotoolkit.org/release-1.6.0/dojo-release-1.6.0/dijit/tests/test_Dialog.html

When you press [tab], your focus will swtich to other object within the dialog box. It work perfect.

BUT if you click the overlay OR the browser url input box and then press [tab], after press serveral time [tab] your focus will be the under the overlay.

then press [space], you can trigger any button under the overlay

Change History (4)

comment:1 Changed 8 years ago by vtsuper

this case happened in IE and FF too

comment:2 Changed 8 years ago by bill

Component: GeneralDijit
Milestone: tbdfuture
Summary: excape dijit.dialog blocking by TABDialog: clicking underlay then pressing tab focuses objects behind dialog

comment:3 Changed 8 years ago by Chris Mitchell

Owner: anonymous deleted

comment:4 Changed 6 years ago by bill

Milestone: future1.6.2
Resolution: duplicate
Status: newclosed

Duplicate of #15370. Obviously this was the original ticket, but I happened to fix it referencing that more recent ticket.

Last edited 6 years ago by bill (previous) (diff)
Note: See TracTickets for help on using tickets.