Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#12474 closed defect (fixed)

IE9: stopPropagation() ineffective on faux keypress event

Reported by: bill Owned by: bill
Priority: high Milestone: 1.5.2
Component: Events Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

See test_TooltipDialog.html.

Open first dialog, click first textbox, type something and press TAB key. Dialog closes.

Although TooltipDialog._onKey() calls evt.stopPropagation() for the faux keypress TAB event, the event still propagates to the containing <div>, where the dijit.popup sees it and closes the popup.

Change History (4)

comment:1 Changed 9 years ago by bill

Component: DijitEvents
Description: modified (diff)
Summary: TooltipDialog: tabbing closes dialog (IE9)IE9: stopPropagation() ineffective on faux keypress event

The problem is that although IE9 supports stopPropagation() natively, it also supports setting evt.cancelBubble, and due to a bug in our code we are first calling stopPropagation() but then setting evt.cancelBubble = false, contradicting ourselves.

comment:2 Changed 9 years ago by bill

(In [24079]) Fix evt.stopPropagation() on IE9 for faux keypress events generated for unprintable characters (like TAB), refs #12474 fixing it on trunk, !strict.

comment:3 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

(In [24085]) Fix evt.stopPropagation() on IE9 for faux keypress events generated for unprintable characters (like TAB), fixes #12474 on 1.6/ branch, !strict.

comment:4 Changed 8 years ago by Kenneth G. Franqueiro

Milestone: 1.6.11.5.2

Updating milestone to 1.5.2 to reflect inclusion in changeset [26956] for ticket #14199.

Note: See TracTickets for help on using tickets.