Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12473 closed defect (fixed)

can't select text in lists (IE9)

Reported by: bill Owned by:
Priority: high Milestone: 1.5.2
Component: Editor Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

See test_LinkDialog.html on IE9.

Moving the cursor over the #1 entry in the list gives a "move" cursor rather than the typical I-beam cursor, and clicking the text will not position the caret

Change History (8)

comment:1 Changed 8 years ago by Kenneth G. Franqueiro

Summary: can't select text (IE9)can't select text in lists (IE9)

I wonder if this is a "feature" of contentEditable in IE9? Seems like ordered/unordered lists are pretty wonky in general (and that seems to be specifically what's eliciting the "move" behavior). It's sometimes hard/impossible to add more items, too (enter inserts paragraphs instead of starting a new item).

comment:2 Changed 8 years ago by Jared Jurkiewicz

I think this is because IE9 is setting 'layout' on the LI. This happens in some cases: http://stackoverflow.com/questions/3603050/remove-resize-handles-and-border-from-elements-with-contenteditable

I think our setting of min-height for LI is the cause in our iframe creation. Working on it now.

comment:3 Changed 8 years ago by Jared Jurkiewicz

(In [24113]) Fixing issue with IE9, editor, and list selection. Setting min-height is turning on layout, which enables those handles. \!strict refs #12473

comment:4 Changed 8 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [24114]) Fixing issue with IE9, editor, and list selection. Setting min-height is turning on layout, which enables those handles. \!strict fixes #12473

comment:5 Changed 8 years ago by Jared Jurkiewicz

(In [24115]) Fixing issue with IE9, editor, and list selection. Setting min-height is turning on layout, which enables those handles, regardless of mode, so have to remove it for IE, period. \!strict refs #12473

comment:6 Changed 8 years ago by Jared Jurkiewicz

(In [24116]) Fixing issue with IE9, editor, and list selection. Setting min-height is turning on layout, which enables those handles, regardless of mode, so have to remove it for IE, period. \!strict refs #12473

comment:7 Changed 8 years ago by Kenneth G. Franqueiro

Milestone: tbd1.6.1

comment:8 Changed 8 years ago by Kenneth G. Franqueiro

Milestone: 1.6.11.5.2

Updating milestone to 1.5.2 to reflect inclusion in changeset [26956] for ticket #14199.

Note: See TracTickets for help on using tickets.