Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#12455 closed defect (fixed)

Setting opacity broken on IE9

Reported by: Louphil Owned by: Eugene Lazutkin
Priority: high Milestone: 1.5.2
Component: Core Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

In IE9, dojox.widget.Standby starts fading in, but disappears when the fading is complete. The effect can be reproduced when trying the examples on http://dojotoolkit.org/reference-guide/dojox/widget/Standby.html in IE9.

Change History (7)

comment:1 Changed 9 years ago by Kenneth G. Franqueiro

Haven't quite gotten to the bottom of this yet, but here's what I have so far:

  • The bug doesn't occur within the animation itself (even breakpointing in onEnd of the fade-in animation, both the underlay and image nodes are still visible)
  • Sometime shortly after the animation ends, the image node "disappears" (as far as I can tell, its opacity becomes 0 again)
  • The next time _size gets called after the animation finishes, the underlay similarly disappears (again, seems like opacity gets set to 0)

The third point above can be easily observed by increasing the interval on which _size is called (on line 501). Not sure if it's in fact an effect of the second point.

comment:2 Changed 9 years ago by Jared Jurkiewicz

This is caused by IE9 finally supporting opacity correctly! There is a conflict going on between dojo's code in dojo/_base/html.js and actual CSS opacity.

The check that does the function assign for opacity config needs to do something like: dojo.isIE < 9, instead of dojo.isIE, and use the standard path for IE9+. Doing that fixes the issue noted here.

Not a standby bug, bug in base dojo.

comment:3 Changed 9 years ago by Eugene Lazutkin

Component: DojoX WidgetsCore
Milestone: tbd1.6.1
Owner: changed from dante to Eugene Lazutkin
Status: newassigned

comment:4 Changed 9 years ago by Eugene Lazutkin

Resolution: fixed
Status: assignedclosed

(In [24090]) IE9 fix: use standard opacity, no filters, thx Louphil, kfg, jaredj, !strict, fixes #12455.

comment:5 Changed 9 years ago by Eugene Lazutkin

(In [24091]) Ported over [24090] fix, !strict, fixes #12455.

comment:6 Changed 9 years ago by bill

Summary: dojox.widget.Standby doesn’t work in IE9Setting opacity broken on IE9

Just fixing title/description for historical reference.

comment:7 Changed 8 years ago by Kenneth G. Franqueiro

Milestone: 1.6.11.5.2

Updating milestone to 1.5.2 to reflect inclusion in changeset [26956] for ticket #14199.

Note: See TracTickets for help on using tickets.