Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12443 closed defect (fixed)

With dijit.Editor on IE changing a font with the cursor on a word, causes the entire word to use the new font.

Reported by: Ed Chatelain Owned by: Jared Jurkiewicz
Priority: high Milestone: 1.7
Component: Editor Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

When the cursor is on a word and the font name or color is changed, it is immediately changed for the whole word even if the word is not selected. If a range of the word is selected only that range is changed, as expected. Selecting Bold, or Underline also has the same problem.

This only happens in IE. Firefox and Chrome behave as expected in that only new characters have the updated formatting.

This is very easy to reproduce with the test_Editor.html test file.

Attachments (6)

12443.patch (20.4 KB) - added by Jared Jurkiewicz 8 years ago.
Patch that partially fixes issue. This bug is exceedingly hard to fix with the way IE handles the actual native/conversion. It's nasty. This patch fixes it somewhat, but it is not complete and has issues. It also includes a bunch of jslint fixes.
12443_2.patch (22.5 KB) - added by Jared Jurkiewicz 8 years ago.
More work on fixing this. It's closer, but not there yet. It's not positioning properly between the split content yet in the case of deep nesting
12443_2.2.patch (24.3 KB) - added by Jared Jurkiewicz 8 years ago.
Yet more work. Seems to now be working. Need to run the automated tests and see if anything fails.
12443_2.3.patch (26.5 KB) - added by Jared Jurkiewicz 8 years ago.
Yet even more work! Passes mouse accessibility, but not keyboard. *sigh*
12443_3.patch (25.3 KB) - added by Jared Jurkiewicz 8 years ago.
Keyboard is now working, but nested styling is still a little glitchy. Needs a bit more work.
12443_4.patch (25.6 KB) - added by Jared Jurkiewicz 8 years ago.
I tink this fixes everything. Seems to be more or less working now. Running UT. If clear, will check in.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 8 years ago by bill

Component: DijitEditor

comment:2 Changed 8 years ago by Chris Mitchell

Owner: set to Jared Jurkiewicz

comment:3 Changed 8 years ago by Jared Jurkiewicz

Milestone: tbdfuture

Waiting on patch. Ed said he was working on one.

Changed 8 years ago by Jared Jurkiewicz

Attachment: 12443.patch added

Patch that partially fixes issue. This bug is exceedingly hard to fix with the way IE handles the actual native/conversion. It's nasty. This patch fixes it somewhat, but it is not complete and has issues. It also includes a bunch of jslint fixes.

Changed 8 years ago by Jared Jurkiewicz

Attachment: 12443_2.patch added

More work on fixing this. It's closer, but not there yet. It's not positioning properly between the split content yet in the case of deep nesting

Changed 8 years ago by Jared Jurkiewicz

Attachment: 12443_2.2.patch added

Yet more work. Seems to now be working. Need to run the automated tests and see if anything fails.

Changed 8 years ago by Jared Jurkiewicz

Attachment: 12443_2.3.patch added

Yet even more work! Passes mouse accessibility, but not keyboard. *sigh*

Changed 8 years ago by Jared Jurkiewicz

Attachment: 12443_3.patch added

Keyboard is now working, but nested styling is still a little glitchy. Needs a bit more work.

Changed 8 years ago by Jared Jurkiewicz

Attachment: 12443_4.patch added

I tink this fixes everything. Seems to be more or less working now. Running UT. If clear, will check in.

comment:4 Changed 8 years ago by Jared Jurkiewicz

Resolution: fixed
Status: newclosed

(In [25558]) Fixing old IE inconcistency with the way bold/italic/underline, etc formatting is handled. Fairly ugly code, had to more or less implement the formatting and bypass much of the native implementation. \!strict fixes #12443

comment:5 Changed 8 years ago by Jared Jurkiewicz

Milestone: future1.7

comment:6 Changed 8 years ago by Jared Jurkiewicz

Milestone: 1.7future
Resolution: fixed
Status: closedreopened

Reopening. Fixed the issue with bold/italic/underline. Have not addressed font name or color.

comment:7 Changed 8 years ago by Jared Jurkiewicz

Resolution: fixed
Status: reopenedclosed

(In [25599]) Fixing issues with fore andhilite color inconsistency across browsers. \!strict fixes #12443

comment:8 Changed 8 years ago by Jared Jurkiewicz

Milestone: future1.7

comment:9 Changed 8 years ago by Jared Jurkiewicz

(In [25600]) Fixing issues with fontname and size on IE. \!strict refs #12443

Note: See TracTickets for help on using tickets.