Opened 9 years ago

Closed 8 years ago

#12440 closed enhancement (fixed)

[patch][ccla]Provides a stock charting demo for mobile

Reported by: cjolif Owned by: Chris Mitchell
Priority: high Milestone: 1.7
Component: Charting Version: 1.6.0
Keywords: 1.7-mobile Cc: ccmitchellusa@…
Blocked By: Blocking:

Description

This demo will highlight some of the features of charting for mobile web including touch interactions.

Attachments (3)

resources.zip (45.9 KB) - added by cjolif 9 years ago.
resources file for the demo (to be extracted in the demos/mobileCharting directory
mobileCharting.patch (14.0 KB) - added by cjolif 9 years ago.
demo patch update with: bug fixes, some design enhancement following Andree suggestions and mouse indicator for desktop (but not BB because you can't really mouse drag with BB trackball witout poping up a window) + fix to avoid resize to be called sevaral times
mobileCharting.2.patch (14.0 KB) - added by cjolif 8 years ago.
new version refactored to use latest version of interaction patch

Download all attachments as: .zip

Change History (24)

comment:1 Changed 9 years ago by Chris Mitchell

Summary: [patch][ccla] Provides a stock charting demo for mobileProvides a stock charting demo for mobile

comment:2 Changed 9 years ago by cjolif

The attached patch (http://bugs.dojotoolkit.org/attachment/ticket/12440/mobileCharting.patch) contains a first draft of the demos thanks to Damien Mandrioli (IBM, CCLA). It will still evolve a bit. For example dojox.mobile parser should be used instead of dojo parser but this is causing issues that need to be solved first. Also charting mobile them should be used when available.

comment:3 Changed 9 years ago by Chris Mitchell

Looks like missing some resource files in the patch, might need to attach a zip. Also, when running on trunk, it's not able to locate TouchZoomAndPan? and interaction base... what are the prereq ticket#'s for this demo to work with trunk? -Chris

comment:4 Changed 9 years ago by Chris Mitchell

Prereq: 12392 ? <== If so, looks like needs to be updated. Missing interaction2d/AxisBase and interaction2d/TouchZoomAndPan

comment:5 Changed 9 years ago by cjolif

12392 is indeed a prereq. You need to take the latest version of the ticket patch. That is: http://bugs.dojotoolkit.org/attachment/ticket/12392/interaction01.patch.

Changed 9 years ago by cjolif

Attachment: resources.zip added

resources file for the demo (to be extracted in the demos/mobileCharting directory

comment:6 Changed 9 years ago by Chris Mitchell

Thanks, got it working! Looks very nice, esp the touch data indicators.

When run on iOS devices (tested with OS4.3 iPad1, iPhone 3gs), the 3m,6m,1y,Max,Touch Mode buttons are only showing a black border, no grey background (so you can't see the white labels). They look fine on chrome and safari desktop browsers.No image "photo.PNG" attached to Ticket #12440

Second issue appears on all browsers, on 6m and 1yr views, stock data is not clipped to plot area. No image "photo2.PNG" attached to Ticket #12440

Orientation changes look good.

Nice work! -Chirs

comment:7 Changed 9 years ago by cjolif

Chris, to fix the clipping issue you need to apply: http://trac.dojotoolkit.org/ticket/12290

For the other issue it really looks like a dojox.mobile issue (these are dojox.mobile buttons). This is working with dojo 1.6 dojox.mobile but indeed upgrading to trunk we get the same result as you. It looks like a regression in dojox.mobile, we will try to investigate a bit.

comment:8 Changed 9 years ago by cjolif

http://trac.dojotoolkit.org/attachment/ticket/12440/mobileCharting.patch is updated to work with trunk, the button issues where to due btnClass->class change in dojox.mobile

comment:9 Changed 9 years ago by cjolif

Some more info:

comment:10 Changed 9 years ago by cjolif

please ignore/delete mobileCharting.2.patch & mobileCharting.3.patch.

comment:11 in reply to:  10 Changed 9 years ago by Chris Mitchell

Replying to cjolif:

please ignore/delete mobileCharting.2.patch & mobileCharting.3.patch.

deleted these.

comment:12 Changed 9 years ago by Chris Mitchell

Summary: Provides a stock charting demo for mobile[patch][ccla]Provides a stock charting demo for mobile

comment:13 Changed 9 years ago by Chris Mitchell

Feature request: please add mouse data indicator support, so that when the demo is viewed on blackberry torch (with mouse cursor) and desktop browsers, the data indicators will appear when hovering over chart.

comment:14 Changed 9 years ago by Chris Mitchell

Owner: changed from Eugene Lazutkin to Chris Mitchell

Changed 9 years ago by cjolif

Attachment: mobileCharting.patch added

demo patch update with: bug fixes, some design enhancement following Andree suggestions and mouse indicator for desktop (but not BB because you can't really mouse drag with BB trackball witout poping up a window) + fix to avoid resize to be called sevaral times

comment:15 Changed 9 years ago by cjolif

with recent dojox.mobile versions it happens we might face a charting bug fixed by #12439. So please make it a prerequesite as well.

comment:16 Changed 9 years ago by Chris Mitchell

no zoom/pan capability with mouse

comment:17 Changed 9 years ago by Chris Mitchell

noticed volume bars sometimes disappear or get rendered with different theme colors after switching y/m/d view.

comment:18 in reply to:  17 Changed 8 years ago by cjolif

Replying to chrism:

noticed volume bars sometimes disappear or get rendered with different theme colors after switching y/m/d view.

I used to get this with old version of #12392 but newer should fix it. Are you sure you are running with latest version? If not then I don't reproduce and need more information like the exact step to reproduce the issue. Thanks.

comment:19 Changed 8 years ago by Chris Mitchell

Milestone: tbd1.7

Changed 8 years ago by cjolif

Attachment: mobileCharting.2.patch added

new version refactored to use latest version of interaction patch

comment:20 in reply to:  16 Changed 8 years ago by cjolif

Replying to chrism:

no zoom/pan capability with mouse

This is in the latest patch.

comment:21 Changed 8 years ago by Chris Mitchell

Resolution: fixed
Status: newclosed

fixed in [24587]

Note: See TracTickets for help on using tickets.