Opened 9 years ago

Closed 8 years ago

#12418 closed enhancement (fixed)

TooltipDialog: allow center arrow and the dropdown itself with anchor node

Reported by: Chris Mitchell Owned by: Douglas Hays
Priority: high Milestone: 1.7
Component: Dijit Version: 1.6.0rc1
Keywords: 1.7-mobile Cc:
Blocked By: Blocking:

Description (last modified by Chris Mitchell)

Popup overlay code should to be able to position callout arrow to center of target node. In order to closely mimic native UI LaF on mobile devices, popup dialog overlays on tablets/mobile devices will need to be styled so that the callout arrow is pointing at the center of the node the dialog is attached to. Currently digit popup only supports pointing to left/right or top/bottom of target node.

Attachments (1)

12418.patch (12.8 KB) - added by Douglas Hays 9 years ago.
patch file and tests

Download all attachments as: .zip

Change History (11)

comment:1 Changed 9 years ago by Chris Mitchell

Milestone: tbd1.7

comment:2 Changed 9 years ago by Chris Mitchell

Description: modified (diff)
Summary: Popup overlay code needs to be able to position callout arrow to center of target nodePopup overlay code should to be able to position callout arrow to center of target node

comment:3 Changed 9 years ago by bill

Owner: changed from bill to Dustin Machi
Summary: Popup overlay code should to be able to position callout arrow to center of target nodeTooltipDialog: allow center arrow and the dropdown itself with anchor node

Dustin said he would work on this so assigning to him for now. Centering the arrow is specific to the Tooltip code, centering the drop down with the anchor node is in the popup.js code.

comment:4 Changed 9 years ago by Douglas Hays

Owner: changed from Dustin Machi to Douglas Hays
Status: newassigned

Changed 9 years ago by Douglas Hays

Attachment: 12418.patch added

patch file and tests

comment:5 Changed 9 years ago by Douglas Hays

Resolution: fixed
Status: assignedclosed

(In [24439]) Fixes #12418. Added new orientation specifications TM (top middle), BM (bottom middle), ML (middle left), MR (middle right) to place.js to allow for centered popups (and tooltips). Changed tooltips to be centered vertically by default. Added automated tests to place.html.

comment:6 Changed 9 years ago by bill

(In [24501]) show off new middle-alignment for above/below tooltips, refs #12418

comment:7 Changed 9 years ago by cjolif

Resolution: fixed
Status: closedreopened

This patch is creating a regression in charting tooltip. Indeed showTooltip used to accepted (in an undocumented manner) a Rectangle (x, y, width, height) instead of a DomNode? for aroundNode parameter. This is not the case anymore cause dojo.position is directly called on the aroundNode. I would suggest even if it was not documented to still support Rectangle because this is very useful for graphics applications (based on Gfx/canvas for example) that do not necessarily have a DomNode? for a drawing.

See also http://article.gmane.org/gmane.comp.web.dojo.devel/14498/match=

comment:8 Changed 9 years ago by Douglas Hays

Resolution: fixed
Status: reopenedclosed

(In [24557]) Fixes #12418. Handle previously undocumented feature of showTooltip to take a dijit.Rectangle object instead of a DOM node reference for the aroundNode parameter.

comment:9 Changed 8 years ago by bill

Resolution: fixed
Status: closedreopened

After [24439] we are getting a failure on IE6 (at least on my machine) on dijit/tests/_base/place.html:

_AssertFailure: [object Error]: assertEqual() failed: expected 1079 but got 1078 with hint: right aligned with around node

comment:10 Changed 8 years ago by Douglas Hays

Resolution: fixed
Status: reopenedclosed

In [26838]:

Fixes #12418. Tweak place tests to workaround IE6 scrollbar bug and to better test % positioning values.

Note: See TracTickets for help on using tickets.