Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#12397 closed defect (wontfix)

dojox.form.FileUploader fails in a dijit.layout.ContentPane

Reported by: oakbehringer Owned by: Mike Wilcox
Priority: low Milestone: tbd
Component: DojoX Form Version: 1.6.0rc1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

Under no circumstances can I get a dojox.form.FileUploader to work when placed inside a dijit.layout.ContentPane. This is surprising.

Inspecting the console, the debug output never gets to "FileUploader flash object ready".

If you create the FileUploader first, it works as expected.

If you create the ContentPane before creating the FileUploader button, the FileUploader button displays no text and is not clickable.

The attached test will demonstrate this, be sure to refresh between clicks/tests.

Attachments (1)

test.html (1.8 KB) - added by oakbehringer 8 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by oakbehringer

Attachment: test.html added

comment:1 Changed 8 years ago by Kenneth G. Franqueiro

This looks like a duplicate of #11039 to me. Anyone else?

comment:2 Changed 8 years ago by bill

Description: modified (diff)
Owner: changed from dante to Mike Wilcox
Priority: highlow
severity: blockerminor

Seems like it, well at least in #11039 it says the FileUploader inside a container without _onShow() needs help to be shown.

But the attached test case has issues:

  1. it looks like it's using the parser since it has dojoType attributes, yet it doesn't.
  2. the test programatically creates a ContentPane but it doesn't call startup() on it.
  3. ContentPane isn't design where you just call new MyWidget() to create widgets inside the ContentPane after the ContentPane is created. The ContentPane should be instantiating the FileUploader when it parses it's contents.

Marking this as low priority since (as #11039 says) FileUploader is deprecated.

comment:3 Changed 8 years ago by Mike Wilcox

Resolution: wontfix
Status: newclosed

Please use dojox.form.Uploader. It uses HTML5 uploaders in order to get around the problems caused by Flash in Mozilla and FF.

comment:4 Changed 8 years ago by OakBehringer

Bill,

You are correct, this turned out to be a duplicate of 11039. However:

1)It doesn't matter if a script has dojoType attributes, but doesn't use the parser. the case happens to be that I was testing both scenarios, to be thorough. I don't see this as an "issue."

2) Whoops. You're right...

3) This makes little sense to me as you seem to be implying that dynamically created widgets are not supported in ContentPane?, if they are created after the pane. You're saying that once I create a ContentPane?, I should not expect to be able to create new widgets in it, possibly in response to user action?

MWilcox,

Thanks. Where do I find a stable release to download with dojox.form.Uploader? Is it recommended to just download the trunk from svn?

http://svn.dojotoolkit.org/src/

Is that considered stable?

THANKS! Oak

comment:5 Changed 8 years ago by Mike Wilcox

comment:6 Changed 8 years ago by OakBehringer

As that is not referenced on your download page, am I to understand that it is in a pre-release phase?

Thanks, Oak

comment:7 Changed 8 years ago by Mike Wilcox

Release candidate one I believe. So it's beyond beta and unlikely to change. And will be the official download very soon.

comment:8 Changed 8 years ago by OakBehringer

Thanks!

comment:9 Changed 8 years ago by Kenneth G. Franqueiro

1.6.0 (linked 3 comments ago) is the stable release of Dojo 1.6. You can find it referenced at http://download.dojotoolkit.org/

It's just not on both CDNs yet and as such the main site has not been updated yet.

comment:10 Changed 8 years ago by bill

@OakBehringer? - officially ContentPane only supports changing the content via set("content", ...) or set("href", ...). If you start mucking with the stuff inside of ContentPane directly that will work (at least in 1.x), but you need to be careful to call startup() and resize() on the new elements.

Note: See TracTickets for help on using tickets.