Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#12394 closed defect (wontfix)

TextBox: sometimes no hover effect (chrome 9)

Reported by: milad Owned by:
Priority: high Milestone: tbd
Component: Dijit - Form Version: 1.6.0
Keywords: Cc:
Blocked By: Blocking:

Description

hi all
dojo1.5:when use claro theme and mouse hover the widget,backgroundColor fade to #E9F4FE.
but dojo 1.6 only in google chrome(my tested version is 9) doesnt add dijitHover dijitTextBoxHover class.
http://download.dojotoolkit.org/release-1.6.0/dojo-release-1.6.0/dijit/tests/form/test_validate.html

Change History (4)

comment:1 Changed 9 years ago by bill

Resolution: wontfix
Status: newclosed
Summary: [regression]some dijit's backgroundColor with claro themeTextBox: sometimes no hover effect (chrome 9)

I'm seeing the same problem in 1.5. Sometimes it works and sometime it doesn't. It's a bug in chrome 9 (works in safari) where spurious onmouseout events are generated right after the onmouseover event.

Since this is fixed in chrome 10 I don't think it's worth trying to fix the problem in our code.

comment:2 in reply to:  1 Changed 9 years ago by milad

you are pro,but i think it's bug,when mouse over the border or over the placeHolder effect work fine.

comment:3 Changed 9 years ago by bill

Yes, as I said above: "it's a bug".

But good news, chrome 10 was just released and the bug is fixed.

comment:4 Changed 8 years ago by bill

Component: DijitDijit - Form
Note: See TracTickets for help on using tickets.