Opened 10 years ago

Closed 5 years ago

#12286 closed defect (worksforme)

ListInput: regExp not validated correctly

Reported by: FreddeFisk Owned by: dante
Priority: high Milestone: 1.11
Component: DojoX Form Version: 1.6.0b1
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by dante)

The regExp attribute in a dojox.form.ListInput? is validated differently by the ListInput? itself and the underlying ValidationTextBox?.

To reploduce:

  1. Go to http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/form/tests/test_ListInput.html
  2. Open the tab "Demo 6".
  3. Enter any string containing at least one digit.
  4. The ValidationTextBox? indicates that the value is invalid (correct)
  5. Press enter to add the item.
  6. The validation done by ListInput? indicates that the value is valid (wrong)

The problem is that the ListInput? doesn't add ^$ around the regexp as the ValidationTextBox? does.

Change History (4)

comment:1 Changed 10 years ago by FreddeFisk

Whops, forgot to preview...

The problem is that the ListInput?? doesn't add ^$ around the regexp as the ValidationTextBox?? does.

comment:2 Changed 10 years ago by dante

Description: modified (diff)
Milestone: tbdfuture

haven't looked at the code, but the test is broken.

comment:3 Changed 10 years ago by dante

(In [24023]) refs #12286 - missing requires making declare throw. should put in 1.6 branch too? \!strict

comment:4 Changed 5 years ago by dylan

Milestone: future1.11
Resolution: worksforme
Status: newclosed

This seems to be working for me today.

Note: See TracTickets for help on using tickets.