Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

#12285 closed defect (fixed)

[patch][cla] ListInput: _onCloseEdit not called after edit

Reported by: FreddeFisk Owned by: dante
Priority: high Milestone: 1.8
Component: DojoX Form Version: 1.6.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

Connecting to "onChange" on _ListInputInputItem._editBox does not have any effect. This makes list item visually stay in edit mode even after the edit is complete.

Also, a minor css error that becomes more visible due to this bug is that the list-style-type:none should be in the ul element, not the li. A fix for that is also included in the patch.

To reproduce: Go to http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/form/tests/test_ListInput.html and edit an existing list item.

Attachments (1)

ticket-12285.patch (1.4 KB) - added by FreddeFisk 8 years ago.
Fredrik Kers

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by FreddeFisk

Attachment: ticket-12285.patch added

Fredrik Kers

comment:1 Changed 8 years ago by freddefisk

The onChange issue seems to be solved in trunk. The "list-style-type:none" error is however still in trunk.

comment:2 Changed 7 years ago by bill

Hmm, after hitting return it looks fine to me, not in edit mode (there is a focus border though).

comment:3 Changed 7 years ago by freddefisk

Yes, it seem to be fixed in trunk. So this ticket can be closed unless you want to fix the CSS issue that was also included in the patch.

comment:4 Changed 7 years ago by bill

Resolution: fixed
Status: newclosed

In [29300]:

fix where list-style-type is declared, fixes #12285, thanks Fredrik

comment:5 Changed 7 years ago by bill

Milestone: tbd1.8
Note: See TracTickets for help on using tickets.