Opened 8 years ago

Closed 6 years ago

#12279 closed defect (invalid)

dojox.charting.Chart2D destroy not working as designed

Reported by: j105rob Owned by: j105rob
Priority: high Milestone: future
Component: Charting Version: 1.5
Keywords: Cc:
Blocked By: Blocking:

Description

It appears that the axes of the chart are not being properly destroyed when calling the destroy function of the chart. However, when calling the removeAxis function, the axis is destroyed properly. Bug 7293 seems to be related, but not totally sure.

learner on the IRC found the problem, postoffice on the IRC and I looked into it and saw that the problem does in fact happen using http://download.dojotoolkit.org/release-1.5.0/dojo-release-1.5.0/dojox/charting/tests/test_DataSeries.html as a test.

Quoting postoffice " <postoffice> calling chartL.destroy() I can confirm that the axis don't get destroyed"...

I found that the difference may be in the fact that the destroy function of the chart calls df.forIn(this.axes, destroy); on line 193 vs the removeAxis function calling this.axes[name].destroy(); then delete this.axes[name];

Change History (3)

comment:1 Changed 8 years ago by Eugene Lazutkin

Milestone: tbdfuture
Status: newassigned

The difference is negligible, and should not be a reason for GC not collecting axes, unless somebody keeps a pointer to the destroyed chart object. Please make sure this is the case.

I keep this ticket open in case you have more details on the problem including what browsers you tried.

comment:2 Changed 6 years ago by cjolif

Owner: changed from Eugene Lazutkin to j105rob
Status: assignedpending

we are still waiting for me details.

comment:3 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.