Opened 9 years ago

Closed 9 years ago

#12277 closed defect (fixed)

Tree: target is null exception on DnD between items

Reported by: bill Owned by: bill
Priority: high Milestone: 1.6
Component: Dijit Version: 1.6.0b1
Keywords: Cc:
Blocked By: Blocking:

Description

There's a failure in the Tree_dnd.html test on FF3.6/win, which can be reproduced manually as follows:

  1. load test_Tree_dnd.html
  2. expand Fruits and then expand Citrus in the lower right
  3. drag banana from top right and drop on Citrus in lower right
  4. drag potato to Orange but don't let go, then slowly move to bottom of Orange, then slowly move down 1 more pixel - at this point the avatar is green but the drop line (indicating that you are dropping after the "Orange" node) has disappeared
  5. drop item (gives "target is null" exception)

The styling is also weird, when the drop line appears (indicating "drop before" or "drop after"), the hovered node still has half of it's hover styling. The background is still blue and the left/right borders are still there, but the top/bottom borders are gone.

Change History (2)

comment:1 Changed 9 years ago by bill

(In [23773]) Fix some Tree CSS issues leading to jiggling during drag-and-drop which in turn can lead to an error on drop. There's still a Tree_dnd.html test failure on IE6 though. Refs #12277.

comment:2 Changed 9 years ago by bill

Resolution: fixed
Status: newclosed

The IE6 issue is just a test problem, starting with [23334], where the itemTree doesn't get the mouseleave event because the mouse is moved so quickly. So the problem of this ticket is fixed.

Note: See TracTickets for help on using tickets.