Opened 9 years ago

Closed 8 years ago

#12262 closed defect (wontfix)

test modules tests.i18n, tests.date.locale, test.number break when using XD/debugAtAllCosts

Reported by: David Rees Owned by: Rawld Gill
Priority: high Milestone: tbd
Component: Loader Version: 1.5
Keywords: Cc: dave@…
Blocked By: Blocking:

Description

As described in this thread, the listed modules fail when XD loaded.

The problem is fixed in 1.6b2 because the modules have been refactored (perhaps to support AMD).

Also see #12260 (Fixes a bug in DOH with regards to XD/debugAtAllCosts) and #12261 (adds debugAtAllCosts parameter to DOH runner.html).

Change History (4)

comment:1 Changed 9 years ago by David Rees

I take back that this is fixed in 1.6b2. What is really happening is that 1.6b2 ignores the debugAtAllCosts (or at least the XD portion of it) since 1.6b2 doesn't support async loading (http://docs.dojocampus.org/releasenotes/1.6#id10). Many of the modules I listed are refactored, but I can't promise they will work when async is supported.

comment:2 Changed 8 years ago by Chris Mitchell

Owner: anonymous deleted

comment:3 Changed 8 years ago by bill

Component: GeneralLoader
Owner: set to Rawld Gill

comment:4 Changed 8 years ago by Rawld Gill

Resolution: wontfix
Status: newclosed

debugAtAllCosts does not work in 1.6. If you really need the functionality, you get get it by doing a xdomain build. Also, v1.7 may be loaded fully async, which makes debugAtAllCosts unnecessary. For now, we have no plans to fix debugAtAllCosts in the src version of 1.6.

Note: See TracTickets for help on using tickets.