Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#12260 closed defect (fixed)

Fix debugAtAllCosts with DOH for 1.5

Reported by: David Rees Owned by: David Rees
Priority: high Milestone: 1.6.2
Component: TestFramework Version: 1.5
Keywords: DOH debugAtAllCosts Cc: dave@…
Blocked By: Blocking:

Description

As described in this thread, DOH 1.5.0 fails if you use debugAtAllCosts.

I have attached a patch file that fixes this for 1.5.0. 1.6b2 seems to fix it as well in a related way (as a side effect of changes to support AMD).

Attachments (1)

fixDebugAllCostsSupportForDOH.dojo-1.5.0.patch (943 bytes) - added by David Rees 9 years ago.

Download all attachments as: .zip

Change History (8)

Changed 9 years ago by David Rees

comment:1 Changed 9 years ago by David Rees

Also see #12261 (Add debugAtAllCosts parameter to DOH runner.html) and #12262 (test modules tests.i18n, tests.date.locale, test.number break when using XD/debugAtAllCosts)

comment:2 Changed 8 years ago by Adam Peller

Component: GeneralTestFramework
Owner: changed from anonymous to alex

comment:3 Changed 8 years ago by bill

Milestone: 1.5.1future
Owner: alex deleted

comment:4 Changed 8 years ago by ben hockey

Owner: set to David Rees
Status: newpending

reesd, it seems from your comments that 1.6 and presumably 1.7 don't have this problem. do we need to keep this ticket open?

comment:5 Changed 8 years ago by David Rees

Status: pendingnew

I think it can be closed as fixed in a later version. Thanks!

comment:6 Changed 8 years ago by ben hockey

Resolution: fixed
Status: newclosed

comment:7 Changed 8 years ago by bill

Milestone: future1.6.2
Note: See TracTickets for help on using tickets.